Sapphire ATI radeon 9550 graphics problems!!! HELP!!!

By Barryatkin
Aug 9, 2006
Topic Status:
Not open for further replies.
  1. well ive had the card for a week, basically replaced my geforce4 because it was getting too out of date for gaming etc!

    since ive had the card in and ran normal functions, the PC has been working fine.
    then.... when i go onto games... the PC just locks without warning, ive NEVER had this problem before with the PC so im blaming the card.

    all advise needed, however ive tried EVERYTHING!! updated drivers, the lot!

    setup is:
    Asrock k7vt4a Pro
    sempron 2300+ chipset.
    512mb DDR400 Ram
    Sapphire ATI radeon 9550 Gfx card
    soundblaster live 5.1 s/card
    usual bits and bobs obviously.
    OS Windows XP pro,

    HELP ME!!! i miss my games :(
  2. iss

    iss TechSpot Chancellor Posts: 2,896

    While it is possible it is the card it is also possible it is your ram. you might want to test your ram with memtest.
  3. Barryatkin

    Barryatkin Newcomer, in training Topic Starter

    not the RAM,

    as i said this system was running perfect before i put the card in, and now its becoming a pain!

    just read in a previous post by wallace about the
    CPU - AGP to PCI - PCI settings, where would i find these if i had them, its worth a try lol
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.