Sapphire ATI Radeon 9800 Pro Problem. Please Help !

By uNreal
Jun 1, 2004
Topic Status:
Not open for further replies.
  1. hello !
    i have this problem :
    i had GeForce 4 MX 440 64mb and games like Counter-Strike (1.5 and 1.6) run with 100 fps all the time. But all other new games like UT2004 and Painkiller ran slowly . I bought Sapphire ATI Radeon 9800 Pro 128 mb and now i have this problem.
    I have 100 fps in cs1.5 , but sometimes when there is many people shooting and stuff , it goes to 60-80 fps , but mailny , its ok in 1.5 . But in cs1.6 now i have like 100 fps when i am just standing, and 50-80 fps when running, shooting somebody, and when there is many ppl on server, the fps may be even 30-50 .
    I heard that some people also had problems with Radeon video cards and cs1.6 . In other forums they say that is it Half-life engine, that it is not supported with ATI cards. OK .
    BUT , lets take UT2003/UT2004 games. I could put everything on LOWEST and low resolution and so on , on my GeForce MX 440, and it would run good. But now it doesnt matter, if there were all settings on HIGHEST or on LOWEST : i have the same frame rates all the time. For example on Asbestos map i have like 80-100 fps when running and shooting, on all LOWEST settings , or on all HIGHEST settings. But on map Plunge, the game is lagging, and i have like 30-40 fps when watching outside, also it doesnt matter if i have all settings on lowest, or on highest ...
    Also some other games, for example Painkiller, when i play the Ruins level with the boss, when he is far away, the game lags and the fps is like 30-40 , only when he is near me, fps is 60-70 , and on other levels it lags sometimes too .
    I think these games shouldn't run this way with THIS video card...

    BTW here are my PC specs:
    AMD Athlon xp 2000+
    512 DDRAM
    Sapphire Radeon 9800 PRO 128mb
    Canyon motherboard
    Windows 2000 sp4
    ------------------------------------------------------------
    please help me :(
  2. (=DoM=)

    (=DoM=) Newcomer, in training Posts: 242

    Well, i'll tell you what will deffinately speed your games up a LOT, upgrade to Windows XP.

    Windows 2000 in my experience of Radeon Cards performs horribly in games, i remember playing MOHAA on Windows 2000 and it was so stuttery, but once i upgraded to Windows XP it was fine, its just 2000 bud, its a bad gaming O/S.

    Go Get XP :)
  3. PreservedSwine

    PreservedSwine Newcomer, in training Posts: 375

    Sounds like something is messed- but if it makes no difference on resolution or detail settings (2 things that are very GPU dependant) the problem most likely isn't the video drivers, but perhaps your mobo/chipset drivers.

    Try re-installing your chipset and AGP drivers, see if that clears things up.
  4. abc

    abc Newcomer, in training Posts: 52

    XP would be a good idea, and the newest chipset drivers are a must. The new 4.6 cats came out today and gave me a VERY noticable increase in performance in Farcry (demo) with a 9800 pro -> 9800 XT. I hadn't bought Farcry for the reason that the demo didn't have the framerates I should have had/ wanted to have. I don't have CS so can't confirm that.
  5. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,802

    :wave: Hello & Welcome to TechSpot :wave:
    I hope you'll enjoy your stay here with us!
    Now over to your problem:

    While I'll support the move to Cat 4.6, I won't say upgrade to XP...

    There is no problem getting games to run in Win2k, except for some older games due to compatibility...
    (As long as the game isn't too shoddily coded that is (painkiller)) (Besides, there's a lot of work needed to remove bloat from XP before it becomes usable imo)

    You have cleaned out every last file and registry entry from your nvidia drivers? (You'll need to use a 3rd party program like Detonator Destroyer/Detonator RIP to make sure it's all gone)

    And what are your 3d setting in the control panel (dekstop-> properties-> settings -> advanced -> 3d)?
    And what is SmartGart set to (dekstop-> properties-> settings -> advanced -> smartgart) & start-> run -> smartgart ?
  6. uNreal

    uNreal Newcomer, in training Topic Starter Posts: 29

    well...
    do you people really think i should upgrade to WinXP ?

    My 3d settings ( OpenGL and Direct3d ) are default (trueform and vsync always off, settings - quality, and anti-aliasing and stuff - aplication preference ) , but if i change them - the difference is hardly seen.
    About smartgart - i have all settings ON
    (PCI Write, PCI Read - on, AGP Write, AGP Read - on)
  7. BrownPaper

    BrownPaper Newcomer, in training Posts: 467

    You probably should not upgrade to WinXP. That would be a waste of money since Win2k SP4 runs good enough.

    I have read a lot of people having problems with Painkiller on various forums (be it ATi or Nvidia). Maybe it is a game issue.

    Btw which Catalyst drivers are you using? I think you should really try the new Cat 4.6. A lot of my games run a little bit faster and smoother than before. Heck even my 3dmark 2001 se scores when up 350 points (if that really means anything).
  8. uNreal

    uNreal Newcomer, in training Topic Starter Posts: 29

    well, i think i dont need help anymore .
    yes, i installed the new cat 4.6 drivers , and they are good.
    I dont play PK anymore , and dunno why, but my CS runs better now ( even with older drivers ) , i tried many things ... the last thing i did is that i put in BIOS "Display init first" to AGP, instead of PCI.
    In cs 1.6 i still have 70-80 fps in some places on de_aztec, but now on all other maps i have 99-100 fps ( with developer 0 ) , even with people . Maybe it's the drivers , maybe some other thing...
    but in august i will upgrade all my pc ( except for video ) and i think with powerful PC + this card i will have NO problems at all...
    CHEERS !:)
  9. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,802

    Well, the 1.2 patch for PK really seems to have fixed quite a few bugs, and given me a nice speed-increase, so you might want to try it again...

    But it's good to see everything worked out in the end! :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.