Satellite keyboard/touchpad unresponsive

By MsMouse
Nov 8, 2009
Topic Status:
Not open for further replies.
  1. I apologize in advance if this has been answered elsewhere. I have Satellite a105-s2194. The keyboard and touch pad stopped working after I edited my registry to fix my dvd burner. I've tried a usb mouse. It shows up but also doesn't work.I can't do a system restore without a working mouse or keyboard so I'm kind of stuck.
    I checked the BIOS and everything is as it should be. Keyboard works in BIOS and system utilities menus.
    Any suggestions would be greatly appreciated. Thank! :)
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    BIOS provides USB support before Windows starts which is why it works in BIOS but not Windows.

    I suggest the best place to start is recovering your files/folders. You can probably just skip to Step 2 for your case See How to recover your folders/files when Windows won’t boot

    Then you can comfortably try fixing your computer (which might need a full reformat/reinstall)
  3. MsMouse

    MsMouse Newcomer, in training Topic Starter

    Thank you! Truely appreciate the help.
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    You're most welcome.

    btw.. once you've recovered your files you'll likely be constrained to work from a boot disk. If you boot into the recovery console you can try
    > How to recover from a corrupted registry that prevents Windows XP from starting
    > Try a system restore from the Recovery Console. Google: system restore recovery console
    > If you have your installation CDs, you can also try a Windows Repair

    Good luck!
  5. MsMouse

    MsMouse Newcomer, in training Topic Starter

    I've printed off the suggested information and am off to try it out. I thank you sincerely for your help! You may have just saved all my pictures of my children and family! (not to mention my sanity) Rest assured if I recover my files I will back up immediately and will post back to thank you again. :)
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

  7. MsMouse

    MsMouse Newcomer, in training Topic Starter

    Finally got knoppix running. However my files don't show up? I'm going to try downloading windows recovery console now that I can access the net from my laptop. Hopefully I can get to my files that way.
  8. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    You successfully booted into Knoppix? And your files don't appear???? Is not a good sign.

    Have you run Step 1 in the post? You should definitely try running chkdsk /r

    /* edit */
    Oh. i see you're going to download recovery console.. ok good
  9. MsMouse

    MsMouse Newcomer, in training Topic Starter

    My hard drive shows up but I get this message:
    unable to mount device
    org.freedesktop.Hal.Device.Volume.UnknownFailure

    Any suggestions? I've been reading the forums for hours and can't seem to find an answer. I've also never used linux before today.
  10. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    OK. At least then it's being detected.

    Do you have your Windows Install CDs (you can use recovery console from the CD)
    or download it. Your next step definitely should be chkdsk /r to check for /clean any filesystem corruption on your hard drive
  11. MsMouse

    MsMouse Newcomer, in training Topic Starter

    I ran chkdsk and it fixed a couple problems. I still can't mount my HD in knoppix. I can run windows but my mouse and keyboard are still disabled. I can't run system restore from the recovery console. Not sure if I have the path wrong or what. I have borrowed an xp disc to see if that will fix the problem. If not I'm going to pull my HD out and connect to another computer to see if I can copy my files.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.