Scariest PC expirence ever

By AtK SpAdE
Apr 5, 2005
Post New Reply
  1. 15 minutes ago.....I just had the scariest thing ever. I was adding a HDD cooler to my rig, and after getting everything mounted, it would not boot, obviously somthing was shorting. So i went back and thorugh a process of elimination i found out that it was a 80mm blue antec exaust fan. It was hooked up thourgh a adapter that plugged it in via a molex. So i uplugged the conector to see if it would work in the 3 pin on my mobo. This is where it gets scary....

    I plugged it in and proceded to boot, next thing i know my mother board starts emitting a show of sparks, and i started flipping out...i insticivley ent for the power swtich which did not work, so i went for the outlet. After removing the fan, everyhitn works fine, but i am still shaking

    A still shaking
  2. vnf4ultra

    vnf4ultra TechSpot Paladin Posts: 1,388

    You're lucky it still works man!
    That would tick me off and scare me at the same time.
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    I'm still shaking too! What a scary read!
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Maybe the sparks are just the latest fashion after cold cathode tubes and leds :giddy:
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I had something similar with my PSU, but unfortunately for me it fried the mobo. Luckily I sent it back DOA :) But I can imagine what you are going through. You are truely lucky you didn't screw something up worse than you did.
  6. zephead

    zephead TechSpot Paladin Posts: 1,569

    sounds scary enough, have you examined the board for cooked parts?
  7. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Topic Starter Posts: 1,495


    Yea i checked throughly nothing looked bad, and every thing works ok...thank goodness

  8. kol_indian

    kol_indian TS Rookie Posts: 316

    had a real scary experience today, the pc suddenly went dead , nothing was working imean nothing just the light was continuesly blinking,

    after some fiddling around found that the moniter plug was(i dont know if that was the real cause yet) after fixing that the computer started and gave an error that bios is corrupted nxt time around the pc started but the my windows did not startup
    non of the options(safe mode, safe mode with networking ............) worked kept on restarting

    now searching for that elusive win xp cd to repair the system.

    hope it works still little suspisious what caused it, was working fine yesterday before i slept got up in the morning and suddenly !!!!!!!!!!!!!!!!

    damn :mad:

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...