TechSpot

Screen goes blank after startup

By korrupt
Jun 8, 2008
Topic Status:
Not open for further replies.
  1. Hi guys,

    I'm having a problem with my old computer...

    Whenever it starts up, it'll go through the boot process... memory check, cd drive check etc etc... but when it usually loads windows it just goes blank. Its a black screen but its definitely not the monitor as i have tested it with others... could it be my video card?

    It could be windows too I guess, but i reinstalled it about a week before it stuffed up and it worked perfect... I am running windows xp and its a really old amd computer but has run without any problems for ages.

    Thanks for any replies.

    Regards,

    Jorrit
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Try Safe mode (repeatively press F8 function key on Windows Startup)
    Then go to Device Manager (Start-->Run-->devmgmt.msc)
    Click the + sign on your Display Adaptor to expand it
    Then right click on your actual Display device, and uninstall it

    Go back to Normal mode (ie Restart)
    Go on the web, and download the most up to date driver for your Display card (from your manufactures support page)
     
  3. korrupt

    korrupt TS Rookie Topic Starter Posts: 1,060

    Thanks mate,

    I tried that, but when it comes to selecting your operating system to boot it freezes up. this leads me to believe that the install has somehow become corrupted so I'm gonna reinstall and see what happens.

    Anyone have any other ideas?

    Regards,

    Korrupt
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.