TechSpot

Secondary HD very slow

By GriF
Oct 1, 2006
  1. Hi guys, I am new to the boards here, and have been having some serious issues with my secondary hard drive. It's basically the same problem as seen in HERE. But the solutions in that thread did not work.

    Well for one thing my seconday drive lists as Primary IDE Channel in Device Manager, and I get a transfer rate is around 2.4 MB/s. Like the other post, I am very up to date when it comes to virii or spy/crap/malware so I know this is not the issue. My BIOS does not recognize my drive ( when I go into setup upon a boot it shows my primary drive in there but not my secondary one), but windows does recognize it.

    I have attempted to uninstall the IDE Channel associated with my drive and install what I think is the correct chipset. If someone could help me out with which one to install, it would be much appreciated.

    Here is the link to my Intel Chipset
    My memory controller - 82915G/P
    My I/O controler - Intel(R) 82801FB I/O controller hub (ICH6)

    Any help with this issue is very much appreciated.
     
  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    are you sure your PSU has enough juice to run two HDDs?

    Do you have something like this set up?
    IDE 0>HDD 1 (OS, Master), Optical drive
    IDE 1>HDD 2 (Master)
    or something else?
     
  3. GriF

    GriF TS Rookie Topic Starter

    Well it is like that except for the optical drive, but I am almost positive I set the secondary drive to slave, (i think i have to actually otherwise it wont boot right).

    And to be honest I don't know an easy way of determining my PSU, other than opening her up and checkin her out.... lol
     
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The BIOS has to recognise the thing. If it doesn't, then something is wrong.

    Instead of being "almost" positive, open up your system and make sure you have set the hard drives to master/slave properly. Mind you, if you are using the 80-conductor IDE cable, then it does matter which plug goes where. Blue - motherboard, black - master, grey - slave. Double-check in BIOS that you have set all IDE devices to be auto-detected.

    It could be that your hard drive takes too long to start up. When you boot up, enter the system BIOS or pause the POST process with the pause key. After a minute, exit the BIOS or continue system startup by pressing any key.
     
  5. GriF

    GriF TS Rookie Topic Starter

    OK well I did not have it set to slave like I should have, I did set it to slave but still have the slowness. Well and the BIOS still doesnt recognize it. I do not have an auto detect function in my setup, but I set my 2 SATA drives to ON as well as the PATA drives.

    My drive is connected with the normal ribbon cables, my primary is a sata drive.
     
  6. GriF

    GriF TS Rookie Topic Starter

    Ok Well I got the drive transfer rate a little better up to 32MB/s, but now the other drive I have connected with the same IDE cable is not being recognized .... lol I didnt know if I had to set it to slave or what, so I tried just taking the jumper off, like I had to do with my HD, ( this is a DVD burner by the way )but that did not work either.
     
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The correct jumper settings should be printed somewhere on the hard drives or at least should be available on the manufacturer's website.. Please make sure the jumpers are placed correctly - randomly playing around with the jumpers is not going to help.

    Replacing/swapping the IDE cable can't hurt either.
     
  8. N3051M

    N3051M TS Evangelist Posts: 2,115

    i've seen HDDs go slow due to the psu not giving enough juice sometimes thats why i've asked..

    Look on the side of your PSU for the info on how many watts it can produce then use this calculator (add 50w for headroom) to find the minimum your PSU should be delivering

    try changing the IDE cable as told above as well.. by the way.. what brand is the HDD(s)?
     
  9. GriF

    GriF TS Rookie Topic Starter

    the HD is a Seagate Barracuda 120GB, I know the jumpers are correct on the HD, just not sure about the DVD burner, I'm going to check the site now, as well as the PSU.
     
  10. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    That's UTA 100 and your seek time is 9.4 with 2MB cache buffer.
    Is that HD making noises?
    Have you defrag is lately?
    What setting did you use for jumpers?
    Power Supply Unit (PSU) depending how many devices you have 400WATTS should be min.
     
  11. GriF

    GriF TS Rookie Topic Starter

    HD doesnt make noise at all, yes I have defragged lately, the HD jumpers are set to slave, but I just wasnt sure if that was right because I have a Primary SATA drive. Didnt know if that would matter.
     
  12. GriF

    GriF TS Rookie Topic Starter

  13. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    Oh you have DELL system, how come you don't go all SATA 100%? Why mix the drives, unless you want to use that Ultra ATA 100 as a USB2 drive? There are kits that are easy to use to make that HD a removable HD. They that slowest problem should go away.
     
  14. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    don't mix IDE and SATA- you'll get problems in the long run even though it will work. Windows defaults to IDE during errors.
     
  15. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Master/Slave only apply to the drives connected to the same ribbon cable. It makes absolutely no difference what you do with other hard drives.
     
  16. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    I say keep the box with the SATA drives and get yourself a USB2 kit for the HD that you want to use in this case the Ultra ATA 100. This way you won't have it slow down on you. Keep the PC running quick with SATA drives.
     
  17. GriF

    GriF TS Rookie Topic Starter

    ahhh ok Thanks alot for the help guys
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...