TechSpot

Selected wrong keyboard layout

By DonNagual
Jan 1, 2013
Post New Reply
  1. Hello, and thanks in advance.

    New computer, just installed windows 8 on it. At the very beginning of the installation process, it asks what layout keyboard you use, and I chose what I always do, English.

    However, this is a Japanese keyboard.

    I am unable to find a way to change it back. Anyone know how?

    (Note: I am not talking about the input method, I am talking about the physical layout of the keys on the keyboard)
     
  2. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,469   +622

    I don't have Win8 handy, but you're looking for this:

    'Region and Language' settings
    Click the Keyboards tab.
    Away you go.

    (Although I quickly looked at layout, and JP & EN layouts look pretty similar)
     
  3. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Yes, the are very similar, but there are changes. I could get by with this Japanese keyboard set as an English one, but I have to search for keys sometimes. All the symbol keys are in a different place than what is marked on my Japanese keyboard. Have to try with the hit and miss method to find symbols as they are all marked differently.

    Can I get by? sure. But I would love to get it back to the Japanese keyboard.

    Now, for your suggestion. Doesn't work. If you look at the attached file, you can see it will let me change the keyboard layout for other languages, just not Japanese. Only gives the option to use the "input method" Microsoft IME. This does not change the layout of my keyboard like the others do.

    Note: I am also using Japanese windows 8, switched to English.
    I have also uninstalled the English pack and went back to full Japanese OS, but the keyboard remains in the English layout.

    When I was installing windows, it asked me what keyboard layout I had, and I selected English when I have a Japanese layout keyboard. That's where it all started.
     

    Attached Files:

  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,346   +49

    Sounds like you need to gain the attention of an actual MS person......or reinstall from scratch. I am staggered by all this - is there really a keyboard used in Japan with English characters on the keycaps, but special characters not in the same order as a US keyboard? Why? And does MS know that? Computers are unnecessarily weird at times, I know.....
     
  5. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Here is a picture of the Japanese keyboard. Look at the shift 2 key for example. It shows the quotation marks. But since I told it I am using an English keyboard, if I hit shift 2 it does that @ mark instead (as it would on an English keyboard). I have that one memorized so all good there, but I don't have the entire English keyboard memorized, so I have a hard time finding the symbols as they are on English keyboards.
     

    Attached Files:

  6. fimbles

    fimbles TS Evangelist Posts: 1,264   +148

    Found this at microsoft community:

    Follow the steps mentioned below to download and install Japanese language pack and check if the issue is resolved.

    a) Press Windows + W keys and type Keyboard layout in the Search box for Settings then pressEnter.
    b) Under Language window, click on Add a language.
    c) Locate and choose Japanese language then click on Add.
    d) Now, double-click on Japanese language to check if language pack is available for the same.
    e) If available, then click on Download and install the language pack.
    f) Once the download is complete, go to Keyboard layout by following step - a.
    g) Double-click on Japanese language and click on Make this the primary language option.
    h) Log off and log on to the computer for the changes to take affect then check if the issue is resolved.

    Hope this information is helpful.
     
  7. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Thank you fimbles, I appreciate your time.

    I did what you have written above. When I switch back to Japanese as the primary language, log off and log back on, the keyboard layout remains English, even though it is set as Japanese as the primary OS language. In other words, the @ mark is where it would be on an English keyboard, but on the actual keyboard itself, the shift 2 key is labelled as the " key.

    I am thinking the only way around this may be a fresh instal. It will ask me again what keyboard layout I am using, but this time I'll get it right, and tell it I have a Japanese keyboard. Wish this could be done without reinstalling!!
     
  8. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,469   +622

    On Win7, when I try to add a keyboard I can choose between Japanese and Microsoft IME.

    See attachment. Can you do this? keyboard.png
     
  9. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    No, it looks like they have completely redone that. And the strangest part is, if I install any other language other than Japanese, I do get the option of setting up the keyboard to match the language. Japanese is the only one I am unable to do that for. I only get the option for IME.
     
  10. fimbles

    fimbles TS Evangelist Posts: 1,264   +148

    Possibly windows reading the keyboard as an english one.

    You can either try the microsoft fix-it (vista only?),or edit the registry manually. Both solutions are listed in this link:

    http://support.microsoft.com/kb/927824

    Hope this helps.
     
  11. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    It wouldn't let me do the 'microsoft 'fix it', so I went into the registry and did the changes they suggest. Didn't work. In all fairness, they did say for windows vista only.
     
     
  12. gbhall

    gbhall TechSpot Chancellor Posts: 2,346   +49

    Well, reading the link given by fimbles #10, I see that effectively they are admitting that some japanese keyboards have an incorrect control chip. Maybe just changing the keyboard (if possible) would solve it. Also, if that is the real reason, then a fresh Windows install only might not solve it.
     
  13. misor

    misor TS Maniac Posts: 1,016   +153

    Have you tried changing the locale language to japanese?
     
  14. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Not sure exactly what you mean, but I have turned the OS to Japanese (windows 8 has that option). So all menus, everything, are in Japanese. Even so, it is assuming I have an English keyboard layout.

    In fact, it was originally the Japanese version of windows 8 which I switched to English (and back and forth, testing the keyboard changes).
     
  15. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Found the fix. Writing it up for those who have the same issue.

    ALWAYS use the Japanese Microsoft IME. Never use the English keyboard option. When you want to type in English use the button to the immediate left of the main IME/keyboard selector. It is the button that will either have the capitol A, or the あsymbol.

    As long as you don`t switch to the English keyboard, and ALWAYS use the Japanese IME (whether it be the A setting or the あ setting), you will be using the Japanese keyboard layout, even in English. Hope this makes sense.
     
  16. Cermet

    Cermet TS Rookie

    I'm having the same problem but I don't quite understand your fix. I tried getting rid of my english keyboard options but @ is still on the 2 key. This happens even if I'm typing in hiragana, so I think my IME is somehow using the English keyboard layout. Do you know if there are setting somewhere to change this?
     
  17. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    What version of windows?
     
  18. Cermet

    Cermet TS Rookie

    Windows 8
     
  19. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    WTF. Now my settings are messed up again, and I can't get the keyboard back to Japanese layout. It was working earlier, I swear!

    I'll mess around again, if I find the fix again, I'll post here.
     
  20. Cermet

    Cermet TS Rookie

    Thanks for the help. I still can't get mine to work >.<
     
  21. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Is your version of windows originally the Japanese version? Also, just to confirm, your keyboard is Japanese layout?

    Mine is the Japanese version of Win8, Japanese keyboard. If I switch the main language (the OS language I mean, not the IME) to English, the keyboard changes to English layout (I.e. the shift 2 key becomes the @ mark)

    If I leave the main OS language as Japanese, I don't have that problem. The keyboard is identified as a Japanese layout.

    I haven't found a way to have the best of both worlds: English OS, with Japanese keyboard layout.
     
  22. Cermet

    Cermet TS Rookie

    Even if I switch the OS language to Japanese and use the IME my layout is an american keyboard layout (@ is above the 2 key, my parenthesis are shifted over a key, etc.). My keyboard is Japanese. I originally selected English as my OS language and later changed it to see if it worked, do you think I should reinstall using Japanese from the start?
     
  23. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    If you purchased the Japanese OS, with a Japanese keyboard, you should be able to have your shift2 button be the " mark. You are not able to? Or was your OS purchased as the English version?
     
  24. Cermet

    Cermet TS Rookie

    It defaults to English, but I remember an option when I installed it for using a Japanese language pack. I ended up going with the English language pack and Japanese keyboard, but that resulted in the wrong layout... I've tried everything I can think of but nothing I do will get the 2 key to have ", etc. I might just have to reinstall and use Japanese from the beginning :/
     
  25. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 3,566

    Yah, I'm not sure how the English / Japanese OS works. For example, I purchased my OS as a Japanese version, then switched it to English. I still see some Japanese here and there in the system though. I wonder if you had to have bought the Japanese version of WIn8 in order for it to recognize the Japanese keyboard?

    If that's the case, I imagine there would be an update to fix that at some point.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.