TechSpot

Selected wrong keyboard layout

By DonNagual
Jan 1, 2013
Post New Reply
  1. JimEagle

    JimEagle TS Rookie

    Hello,
    My laptop was purchased in Japan with Japanese keyboard and Japanese version of Win 8. I cannot recall the setup steps exactly, but I guess I would have selected Japanese keyboard.
    I have experience with English XP and Japanese keyboard, when the best way to arrange is Japanese input using Japanese keyboard and then change to "Direct input" to input English directly when required, so I would have selected Japanese keyboard this time around. I am sorry, I cannot help you with how to switch keyboards, but I have some comments as to how my PC is set up that might give some hints.
    I found that everything I did before I installed the English language pack is still shown in Japanese text after the language pack was installed. Eg, I accessed a wifi network before the installation of the English language pack and the network name continues to be in Japanese. This might give some hints as to why some of your text is in Japanese as well.
    I found that when using the English language pack, on startup I have the English keyboard. Once the Japanese IME is installed, all I need to do is change the input (bottom right on taskbar) from ENG to Japanese Microsoft IME and the keyboard changes to Japanese layout. Each time the PC is started it starts up on ENG and I need to make this change manually, I have not yet found the means to change this automatically on startup.
    If this works for you, then I would really appreciate some technical assistance with automatically changing the input setting on startup, as I have yet to find a solution to this.
    Hope this is useful.
    Best regards
     
  2. pluto

    pluto TS Rookie

    Ok... this was so painful. I've had a similar problem.

    The instructions at http://support.microsoft.com/kb/927824 are correct and work for Windows 8.
    Do edit the registry yourself. I haven't tried the program, but you don't really need it since it's just a few registry entry edits.

    I installed a Japanese version of Windows 8 on a US Keyboard laptop. I forgot to select the keyboard settings on install.

    Therefore, I had : when I wanted ', and so on. All the symbols were everywhere.
    Carefully change the registry values as outlined on that page. Choose the format you want (US and Korean keyboard values at the bottom).

    One final tip. When doing this, change your password to something simple!
    Since I couldn't see what I was typing when I set the password, I had no idea I was using unintended symbols from the different layout. After I fixed the layout, I spent 30 minutes, and probably 50 or so attempts to try and log back in. Change your password temporarily to alphabet only, symbols will screw you over!

    Final slightly unrelated note:
    The language packs that you can install on top of your installations (Windows 7 Ultimate and Windows 8) do not actually change the version. So if you install an US English Windows, applying a Japanese language pack will change all the menus into Japanese, but in the end it's still a US_EN version.
     
  3. altkitakyushu

    altkitakyushu TS Rookie

    Hi guys! I also experienced this. I bought a Japanese laptop (windows 8) and installed the English language pack. Now it's running in English OS. I already had fixed the keyboard layout problem. Here's the file I used. I just clicked the registry file (jkeyb), clicked yes, then it was done. Don't forget to always use the Japanese Microsoft IME keyboard. Hope this would help you.
     

    Attached Files:

  4. Flashinthejapan

    Flashinthejapan TS Rookie

    Had the same issues with this. Hope this rather cheesy video someone made might help, to do with the 106/109 keyboard.
    Have to admit though it hasnt been a fulltime fix and sometimes have had to redo.

     
  5. Brandonburi

    Brandonburi TS Rookie

     So I gave that a try on my Japanese Bought 8.1 machine, but got a little lost. Didn't really see how to do what you said. Mind giving a bit more detail?
     
  6. Erika.AHQ

    Erika.AHQ TS Rookie

    I am experiencing the exact same problem atm. I have a laptop bought in Japan, with Windows 8, and I installed English keyboard. It was fine for a few weeks, both when I typed in Japanese and English (and also Spanish, which I installed around the same time as English). But now all my symbols are messed up. The @ is in shift+2, the + is in shift+^ and so on. I don't know how to fix it :/ Any help? Please!
     
  7. mike1959

    mike1959 TS Evangelist Posts: 1,162   +29

    If you have the options installed then you can use the 'Windows/start key' + space to switch between them, or LEFT-click on the language layout next to the left of the time; eg 'ENG UK' and the options will show onscreen.
    switch_lang.jpg
     
  8. Brandonburi

    Brandonburi TS Rookie

    Fixed, sort of.

    Do to another mess up I had to restore my system, and after I did that it worked fine after I kept the Japanese IME selected. Not recommending you do this, but it is what worked for me. Up until that point I simply made stickers and put them on the correct keys.

    Do note that if you type in the \ character on power-shell in the Japanese version in will read as a yen sign ¥.
     
  9. museovivo

    museovivo TS Rookie

    I had the same issue, the solution pluto posted worked perfectly for me on Windows 7.

    I followed the instructions on the link he provided: http://support.microsoft.com/kb/927824



    << Start the Registry Editor:

    For Windows 7 and Windows Vista:
    Click StartStart button, type regedit in the Start Search box, and then click regedit in the Programs list.

    User Account Control permission If you are prompted for an administrator password or for confirmation, type the password, or click Continue.

    For Windows XP:
    Click Start, click Run, type regedit in the Open box, and then click OK
    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters
    Right-click LayerDriver JPN, and then click Modify.

    Note If the LayerDriver JPN registry entry does not exist, create it. To do this, right-click a blank area in the details pane, point to New, and then click String Value. Then, type LayerDriver JPN to name the new string value.
    In the Value data box, delete the existing value, type kbd106.dll, and then click OK.
    Right-click OverrideKeyboardIdentifier, and then click Modify.

    Note If the OverrideKeyboardIdentifier registry entry does not exist, create it. To do this, right-click a blank area in the details pane, point to New, and then click String Value. Then, type OverrideKeyboardIdentifier to name the new string value.
    In the Value data box, delete the existing value, type PCAT_106KEY, and then click OK.
    Right-click OverrideKeyboardSubtype, and then click Modify.

    Note If the OverrideKeyboardSubtype registry entry does not exist, create it. To do this, right-click a blank area in the details pane, point to New, and then click DWORD (32-bit) Value. Then, type OverrideKeyboardSubtype to name the new DWORD value.
    In the Value data box, delete the existing value, type 2, and then click OK.
    Right-click OverrideKeyboardType, and then click Modify.

    Note If the OverrideKeyboardType registry entry does not exist, create it. To do this, right-click a blank area in the details pane, point to New, and then click DWORD (32-bit) Value. Then, type OverrideKeyboardType to name the new DWORD value.
    In the Value data box, delete the existing value, type 7, and then click OK.
    Exit Registry Editor. Then, restart the computer. >>



    I haven't tried the jkey.zip file altkitakyushu provided, that might work as well maybe.

    Cheers.
     
  10. k7532

    k7532 TS Rookie

    The jkey.zip file didn't work. Not only did it not work, I now no longer have a Japanese keyboard to choose from so my OS doesn't recognize the Japanese keyboard anymore.

    I would not recommend using her fix without understanding it first.
     
  11. sadman3

    sadman3 TS Rookie

    Just go in Region and Language and change it :)
     
     
  12. This is a very late reply, but might help someone. I have found in many versions of Windies since 2000 that you have to change the keyboard driver. It's not enough to add a keyboard in the Language settings. For some reason an English version of Windows always chooses the default English keyboard driver. Go to device manager to change the driver. Don't allow the wizard to choose the default driver, but deliberately choose the Japabese 106-key driver and ignore the erroneous warning about this being the wrong choice.
     
  13. A late reply but since I have struggled to find a solution to a similar problem, here it is for whoever it might help:

    I have an Asus laptop, Japanese keyboard, Windows 8, then 8.1 and several users. One with Windows displayed in Japanese and Japanese keyboard input which never had any problem.
    My account on the other hand had problems. I have Windows displayed in English, and of course I have the Japanese keyboard, which is the physical layout, as well as French. Since the Windows language display is English, the ENG keyboard layout was added automatically even though I don't need it (everything on the US keyboard is on the Japanese ones). I didn't mind, except after a while, the US layout was always on EVEN THOUGH I selected the JP one. So basically, symbols in the wrong place, and impossible to input Japanese.
    I saw many solution involving tinkering with registry but here is the one that has worked for me:
    1. In Control Panel, change input method. ENG was the first choice since it is the language of Windows, JP was 2nd, and FR 3rd. I moved JP first and restarted. Now windows was in JP and keyboard had no more problem.
    2. Same place, I selected "options" for JP and then I chose override the language display, and selected English in the list. Restart. Now I have windows in English, and no more problem with the JP keyboard layout.
    3. Since ENG was now 2nd on the list, I deleted it, and I have just JP and FRE as input method and English as Windows language display.

    Hope this helps.
     

Similar Topics

Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...
Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.