Sims 2 directx issue

By animechick6546
Apr 7, 2008
Topic Status:
Not open for further replies.
  1. So I've seen a thousand of these things. "failed to enumerate any directx blah blah blah" program will now terminate.
    Tell you the truth, the sims is starting to tick me off between telling me my discs aren't authentic and failing to open the programs afterwards.
    Anyhow, I've had my computer since like... november? And I've been playing ts2 since. I've got a really nice computer, with an nvidea geforce 8300something. It's my pretty li'l gaming system.
    I have all the drivers updated, directx 10, whatever. It's stupid that this error is popping up, and in none of these threads is there an answer. Soooo
    Any help? Do I need to do one of those system scan thingymabobs?
    Thanks in advance, everyone! =D
  2. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    If I'm reading this correctly, you have been playing Sims 2 before on this PC and now it has developed this problem?

    Have you installed the patches for your game?
  3. animechick6546

    animechick6546 Newcomer, in training Topic Starter

    Yeah, when I installed my patch, the securom stuff popped up and ticked me off. I had to contact them to get a new launcher. Ridiculous, I tell you.
    So yeah, I have freetime, if that makes a difference. Everything is up to date, my drivers for my card, the directx, and the game. I just can't find a solution. Uninstalling and reinstalling isn't something I want to do for the simple fact that I lost the first disc for pets.
  4. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    Since it worked before but not now, I was going to suggest uninstalling and reinstalling. I guess that won't work in your case. I seems to me some file or files might have been corrupted somehow. A reinstall would prove or disprove that.

    Did you install any new software or hardware just before you noticed the problem?
  5. animechick6546

    animechick6546 Newcomer, in training Topic Starter

    I actually tried system restore to a day when it was working, and it gave me the same stupid error.
    Seriously, I blame the sims XD If they do this stuff to spore, I'm gonna be a very unhappy camper.
    But yeah, I figured it was something corrupted too, but I haven't DONE anything to warrant a corrupted file. I mean unless they just mess up on their own <.<
  6. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    It could have happened due to an improper shut off of your PC while the game was loaded or perhaps a power failure or something like that. But if a file is corrupted, how it got that way is less important than fixing it.

    When you updated your graphics driver, did you uninstall the old one first? You probably did but I'm grasping for straws.
  7. animechick6546

    animechick6546 Newcomer, in training Topic Starter

    Well there isn't an update for my graphics driver? I don't think so at least.
    I mean I guess I could uninstall and reinstall it?
  8. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    What I meant was, you said you updated all your drivers. So when you updated your graphics driver to the latest one (I presume), did you uninstall the old graphics driver before installing the new one? If not, you should have.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.