TechSpot

Sims makin' magic, installation problems.

By oliviabacks
Jun 11, 2007
Topic Status:
Not open for further replies.
  1. ok so I have the same exact problem. I am trying to install the sims makin' magic and nothing happens. Except the following:

    Installshield Wizard

    the sims makin' magic setup is preparing the installshield Wizard, which will guide you through the rest of the setup process. Please wait.

    and then shortly after a box pops up saying:

    The Installshield engine (ikernel.exe) could not be installed.
    incorrect function.



    I've tried the ctrl + alt + delete and I didn't even have the ikernel.exe on the task manager.

    So I was unable to fix it.
    I am really stressed out right now and really really need help with this stupid ikernel.exe installshield problem.

    Someone please!!!!! help!!!!
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Post moved to it`s own thread, rather than leaving it in a very old thread. ;)

    Regards Howard :)
  3. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    i know. but everything about ikernel.exe problems is like really old. and your not helping me
  4. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    I am trying to help you. That`s why I moved your other post to it`s own thread.

    Checkout this link for ikernel.exe problems.

    Regards Howard :)
  5. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    what? really you are no help. I just made one of these profile things like 20 minutes ago. Do you actually think that I know how to post one of these things? because I don't. I need help and if your not gonna help then stop writing.


    Some tech helper you are.

    than please help!

    i've already seen that. but I didn't understand the instructions. I didn't know play by play what to do where to go all that stuff. I need more specific stand by help. please help?
  6. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Posts merged into thread.

    Just lose the attitude now.

    Which bit of the instructions in the link I gave you don`t you understand?

    Try this.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Then navigate to the following folder.

    C:\windows\system32 and look to see if these three files are present.

    Stdole32.tlb
    Stdole2.tlb
    Stdole.tlb

    Let me know if they are.

    Regards Howard :)
  7. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    how do I navigate to that folder? sorry about the attitude.

    umm for the windows explorer, what is that? a cd do I need or something?
  8. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Double click My computer, then your c drive, then the windows folder, then the system32 folder.

    Regards Howard :)

    Edit: I`m trying to walk you through the steps in the MS article.

    I need you to tell me if the 3 files are there.
  9. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    ok i do not have stdole.tlb
  10. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Ok, now we might be getting somewhere lol. I take it the other two files are there as they are supposed to be?

    Download the attached zip file and save it to your desktop. Extract it and place the resulting file stdole.tlb into this location. C:\windows\system32. Reboot your system and see if you still have problems.

    Regards Howard :)

    Attached Files:

  11. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    ok so what now? lol step by step like the double click my computer then click etc..... thing. Sorry if I'm a pain, I just need step by step and what is extract and replace the file?

    yes I have the other two. lol

    and how do I reboot my system, do you mean restart my computer?

    hold I think I just figured the first couple steps lol.

    ok so what I did first was i clicked that attachment and clicked save when the thing popped up. I saved it to the system32.

    Did I do the steps correctly, or Am I missing something?

    what next?
     
  12. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    The file I attached is a zip file with the file you need inside. What you needed to do was save it to your desktop and unzip(extract the file from inside. You do this by right clicking the zip file and choosing extract file. Then, once you`ve done that, you place the stdole.tlb file in your system32 folder and restart your computer.

    Regards Howard :)
  13. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    ok so while i sent you that last post. I realized what I did wrong and corrected myself. lol Instead I deleted the file because I looke next to the stdole32.tlb and stdole2.tlb and it said stdole.zip

    I figured that was wrong and read over the directions again. I realized to open the attachment and download it instead of saving it first. Then it gave me the option to extract all files. I chose that zip file and extracted it to the system32. Then I checked system32 and there it was!!! stdole.tlb!!!

    all I have to do now is restart the computer and try to install the game again. correct?

    thank you so much, I really hope this will work lol.
  14. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Yes, restart your computer and see what happens. Hopefully, if we`re lucky, it`ll work and you won`t have any other problems.

    Regards Howard :)
  15. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    houston we have a problem.

    now.... its says instead of "incorrect function"

    it now says: Data error (cyclic redundancy check).
  16. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Damn, that`s not good and probably means there`s a problem with the game cd/dvd.

    Make sure the cd/dvd is clean, free from fingerprints and not scratched. Then, try installing again, possibly even using a different cd/dvd drive, if you have one available.

    Regards Howard :)
  17. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    well the reason this whole problem started was: I tried to install sims superstar to see if it would work. Because I wasn't quite sure if my computer had enough memory since its like 4 years old. So about 3/4 the way of installing it. Something happens and it didn't work. So I tried to put the makin magic cd in to see if that still worked and If I could still play it. Unfortunately it said something bad like it didn't work and to try and reinstall it. SO I uninstalled the whole sims and tried to install it over again. Then these problems occured. I'm pretty sure its not the cd. Because it was working fine yesterday just maybe the computer is really old or something? I'm not sure.
  18. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    You could try doing a system restore to before your problem occurred.

    Click start/all programs/Accessories/System tools/System restore/Next and choose a restore point from before your problems began. Follow the onscreen prompts.

    Regards Howard :)
  19. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    ok never mind. so now I feel really stupid. Because I didn't possibly think that my cd was dirty or anything. But after a while I got desperate so I took the cd out. And to my knowledge the cd WAS dirty. So I cleaned as bet I could and put it back in. AND GUESS WHAT!!!!


    its installing!!! hahaha yessssss
  20. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    That`s great news. Hopefully, that`s it now lol. I`m off to bed shortly as it`s 3:30 am here and I`m tired.

    Regards Howard :)
  21. oliviabacks

    oliviabacks Newcomer, in training Topic Starter

    ok thanks. i'll let you know if it installed successfully in the morning! lol


    thanks again!
  22. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    No worries, I`ll keep everything crossed for you lol.

    Regards Howard :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.