Sloooooow internet... still cannot figure this out

By Mamut0o1
Sep 9, 2013
Post New Reply
  1. Good afternoon all,
    I have a Compaq Presario SR5050NX. It originally had Vista installed and I just upgrade it the PC to Win7. The PC used to work OK using the cable modem only but now that I added a Cisco E1200 the internet is very slow! So I thought maybe if I upgrade it to Win7 the problem will be gone but still I am unable to download anything and the websites take forever to display. I have updated the chip-set and according to HP the network driver that comes with windows 7 should work and it does! if I use the modem but not with this router. Can someone give me a hand with this? Do I have a defective router?
  2. jobeard

    jobeard TS Ambassador Posts: 13,286   +281

    Always test the TCP connection to your ISP first.

    use command prompt and enter IPCONFIG /ALL

    now
    • ping the gateway address shown
    • and the DNS addresses given

    Then use your browser to find the ip address assigned by your ISP
    and ping that address too.

    Verify how robust your ISP connection is by testing with
    • pathping xxx
    • pathping yyy
    where xxx is the first DNS address shown abovve
    and yyy is the address from http://www.whatismyip.com/

    There should be no timeouts in any of these results.
  3. TheHawk

    TheHawk TechSpot Enthusiast Posts: 190   +6

    Hey Mamut0o1.

    What happens if you connect the pc straight to the modem, is the speed better ?.
    Do you live close to others and did you secure your router when you installed it ?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.