Slow burn speed for new DVD burner

By JeffRI
Nov 4, 2005
Topic Status:
Not open for further replies.
  1. I am brand new here so I apologize if I am not super-technical. Thanks in advance for any help.
    I bought a Sony DRU810 DVD burner installed it in my two month old Dell 3000. It worked fine, with the exception that it would not burn any faster than 1.5x. The computer already had a factory installed DVD/CD-RW drive in the top slot. I put the new drive in the second slot, and connected it to the same ribbon that that already existing drive was connected to. I set the new drive as slave.
    I backed up two DVD's and both came out fine, but even though I had it set to burn at 4x, it only went at 1.5x. The media I had was approved for 8x, so that is not it.

    Any ideas what may be causing this and how to fix it?

    Thank you much.
  2. mailpup

    mailpup TS Special Forces Posts: 8,410   +213

    This may have nothing to do with it but don't assume the original combo drive was set to master. It could be set to cable select. One of the Dells I have is like that (never looked at my other one). I found out when I replaced a bad drive. If so, you can set the new drive to cable select too or set the original to master.
  3. JeffRI

    JeffRI Newcomer, in training Topic Starter

    Thanks, I'll take a look at the original drive to see how it is set. I also noticed that even though in the device manager the 'DMA when available' is selected, it is still operating at 'PIO only'. I've heard this can be corrected by uninstalling the IDE channel, and rebooting.
  4. JeffRI

    JeffRI Newcomer, in training Topic Starter

    Would having 1 drive set to cable select, and another set to slave, cause the slave to run slowly? or would it just make it not work at all?
  5. mailpup

    mailpup TS Special Forces Posts: 8,410   +213

    Regarding the DMA - PIO issue I found an article that discusses it and provides a solution you could try. Perhaps you already read it but you can click here to see it.

    As to your second question about mixing the jumper settings, I don't know. I know they should be both set to cable select (if your system supports it) or they should be master/slave but I don't know the consequences of not following that rule.
  6. JeffRI

    JeffRI Newcomer, in training Topic Starter

    Thank you very very much! It was actually the Bios. I went in and saw that the slave secondary drive was turned off, causing it to act the way it did. I set it to auto and all worked like it was supposed to. Thanks again!
  7. mailpup

    mailpup TS Special Forces Posts: 8,410   +213

    Follow up:

    By coincidence after I posted my last message above, I just finished building a new PC for someone else and one of the two optical drives, a Liteon 1693s DVD burner, began to operate extremely slowly. After checking for any firmware, driver and DVD burner program software updates, I came back to this thread and reread the article to which I linked. Low and behold, that was the problem. Windows had switched that drive in the IDE controller from DMA mode to PIO mode. Manual switching within Windows didn't work but uninstalling the controller through Device Manager and restarting Windows did the trick.

    In trying to help someone else, I ended up helping myself. :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.