Slow connection on Belkin adapter

By x_kilo_x
Sep 11, 2007
  1. Hello,
    I'm using a Belkin Wireless-G+ router.
    I've got two computers, one using a Linksys adapter and one using Belkin.
    I plugged the router into the cable modem and both computers worked just fine, but I went ahead and configured the router using the installation CD anyway. I didn't put in any security information or anything, the program just ran, asked me to specify an SSID, then it said "sending information to router" for a bit and that was it.
    The computer with the Linksys adapter still works fine, but after I configured the router, the computer with the Belkin adapter now runs very slowly. When it first connects is says 54 mbps and then it gradually drops down to 1mbps, and runs either very slowly or not at all.
    There aren't any error messages to go along with it, as far as my computer's is concerned everything's working fine.
    Any ideas?
    Thanks in advance.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Replace the Belkin adapter with any other brand like D-Link or Netgear
  3. x_kilo_x

    x_kilo_x TS Rookie Topic Starter

    So does Belkin just suck? :p
    I wanted NetGear but apparently the Wal-Mart I went to doesn't carry them anymore.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    I've had some trouble with Belkin in the past... Can you still get linksys at Wal-mart? I think ours has them still. I got my Netgear from Newegg. It is sweet!
  5. x_kilo_x

    x_kilo_x TS Rookie Topic Starter

    I've had bad experiences with Linksys too.
    Guess that leaves NetGear.
  6. tipstir

    tipstir TS Ambassador Posts: 2,383   +105

    Belkin 54G 54G+ PCMICA WiFi Cards work fast then slow down. Even if you don't use the software that comes with it and just use Windows XP Pro SP2 Wi-Fi management. It still seems to slow down or fail. I switched to Buffalo 54G Turbo HP (high power) with upto 125Mbps. I have no problems.
  7. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    just update the belkin firmware. also set your router for G-ONLY!
  8. tipstir

    tipstir TS Ambassador Posts: 2,383   +105

    Still acts up jobeard, not much you can do... I already set my router to G-Only... Belkin had reported they had problems with 4, but I had the 5. I don't know about 6 model.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...