TechSpot

Sony PCG-fx270k drivers

By pika22691
May 12, 2008
  1. Hi, I just formatted my hard drive and install a fresh copy of windows 2000 and when I tried to reinstall the drivers that I downloaded from the sony website it does not work. There was an error message that says the program is not designed to run on this computer. Then it has another message saying "your computer contains the wrong model information". The only driver i was able to install was the sound. Thanks for the help in advance.
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Are you certain you downloaded the correct drivers? What are the names of the files you tried to install?
     
  3. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

  4. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Try installing only the drivers from the "Original" tab and not the "Update" tab, at least at first. Some of the drivers require other drivers to be installed first. Check the "See more" link before going ahead. Note that they all have installation instructions. Are you following them? I'm not saying you're not but just checking.

    Edit: Don't do anything with any of the BIOS downloads.
     
  5. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    yeah i tried them and followed the instructions but it never works.
     
  6. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Can you go to the Control Panel and click on "System" to confirm the model number? Since the drivers don't seem to recognize the laptop, maybe there is a problem in that area.
     
  7. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    In the system properties, under general tab. It says system: Microsoft Windows 2000 and then 5.00.2195

    Is that the model number?
     
  8. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    No, that's the Windows 2000 version. Under the General tab farther down I was hoping it would give a brand or model number we could use to confirm your model number. If it's not there, oh well, I guess that didn't work.

    Edit: Try going to Start > Programs > Accessories > System Tools > System Information. See if that gives any model number info.
     
  9. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    Oh. Well the only things that are left in that tab is:

    Registered to:
    ...
    ...

    Computer:
    x86 Family 6 Model 8 Stepping 10
    AT/AT COMPATIBLE

    Edit: I went there and it said: System Model: PCG-FX270K(UC)
     
  10. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    It appears you have the model number correct so I can't account for the error messages.

    I don't know if this would matter but is the Windows 2000 CD from Sony or is it a "regular" Windows 2000 CD?
     
  11. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    it is the regular Windows 2k CD. I have one question what does the (UC) stand for?

    Edit: I somehow got the wireless internet to work. do you think it will be better if i update everything first and try to install the drivers again afterwards?
     
  12. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    I found out. It means U.S. model / Canadian model.

    Edit: Ordinarily I would install the drivers first but if there is no other way, you do what you can.
     
  13. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    I'll try to search around. the small screen that is on the laptop is starting to hurt my eyes though lol.

    Edit: Okay, now i got the display adapter. I have another question. I have a missing driver that says pci device. What is that?
     
  14. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Any other devices in your laptop like a modem or something?
     
  15. pika22691

    pika22691 TS Rookie Topic Starter Posts: 22

    oh, i was able to find all the other drivers by searching them. It turns out that i can get most of them from the intel website. so i guess my problem is solved. thanks for helping me mailpup.
     
  16. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    You basically, solved it yourself. Good for you.
     
  17. paxantony

    paxantony TS Rookie

    need help

    i've just reinstalled xp on drive and the Fn keys don't work, I'm guessing that i need a driver any one know which one and where to get it?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...