Sound card echo

By Tomi-Wan
Nov 11, 2005
Topic Status:
Not open for further replies.
  1. I've recently been getting an echo from my sound card. I have not added any new hardware or drivers from when it was working fine until the problem began. Is there a way to shut off the echo or perhaps find the cause? Thanks

    Here is my system info:
    Operating System Windows XP SP-1
    Processor AMD Athlon XP 2000+ 1.66GHz
    RAM 512 mg
    Hard Drive 20 gig & 120 gig
    Monitor TRL/RIC DH-1764M/DH-1764
    3D Video Card Sapphire Radeon 9600 Atlantis 256 mg
    Display 1024 x 768 32-bit
    Mouse PS/2 Compatible
    CD Rom 16X DVD/48X CD ROM
    Sound Card Sound Blaster Live! Audio 9000
    Speakers Logitech Z-640 6 Speaker Surround Sound
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Turn off environmental effects in the Creative control panel or set reverb to zero manually. Search these very forums or Google - it is a very common issue.
  3. Tomi-Wan

    Tomi-Wan Newcomer, in training Topic Starter Posts: 29

    Thank you very much.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.