TechSpot

Sound Control Opening With Heavy Delay

By joshieboy
Aug 8, 2013
Post New Reply
  1. Hey everyone,

    So I am using Windows 7 and I have been trying to open my Sound options under my Control Panel to no avail.

    When I click on the "Sound" text, my Control Panel box slightly fades as if a window is going to open but no such window ever does. 5-10 minutes later, the sound controls will finally pop up. It is experiencing some kind of heavy delay.

    I have been told it may be a driver issue but my drivers are relatively new (3-4 weeks old).

    Let me know if you guys have any solutions.

    Thanks.
     
  2. sentrycube

    sentrycube TS Member Posts: 17

    Hmm, could be a bug with the new drivers.

    Try un-installing all audio devices and then re-install.
     
  3. I think sound card settings should be open easily by control panel if it is not than there is problem with your system's driver. re-install it.
     
  4. joshieboy

    joshieboy TS Enthusiast Topic Starter Posts: 52

    Alright one thing, I don't have sound card. Should I re-install the drivers for my motherboard? I find that when I am not running anything with sound, I can open it instantly but when I attempt to do so when I have something playing sound (even if the sound isn't on) it will have a delay.
     
  5. stonarda

    stonarda TS Enthusiast Posts: 141   +18

    You will have a sound chip integrated into your motherboard, just continue as though you have a sound card and follow the mentioned steps...
     
  6. joshieboy

    joshieboy TS Enthusiast Topic Starter Posts: 52

    Worked. Thanks guys.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...