TechSpot

Sound is distorted when over 50% volume

By devilsfury
Dec 1, 2011
Post New Reply
  1. Hey all! Ive been having this crazy issue that if I put my master volume over 50% it starts making this high pitch squelching noise and it only goes away if you mute it. Im using a Creative SB X-FI sound card but thats not the issue. Ive replaced it with 2 totally different sound cards with the same result. Went in and completely removed all drivers and reinstalled with the most up to date drivers with the same result. Ive even placed the different cards in different slots on the board. I dont understand. Plus to make issues worse my mic doesnt want to work either. Maybe there is a conflict on my board or something? Im at a loss. Help!!
     
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Time to remove the software, then use something like RegEdit to take off all remnants of the old install, and THEN reinstall the drivers... that will tell you if the issue is elsewhere requiring a reinstall of Windows... or a Repair install.
     
  3. devilsfury

    devilsfury TS Rookie Topic Starter

    Im so dumb! I totally forgot about going into Regedit and removing everything having to do with the old drivers. After about an hour of killing everything Creative or X-fi I reloaded drivers and now it works like a charm! Thanks for your help!
     
  4. tweakboy

    tweakboy TS Guru Posts: 467

    Its your speakers my friend. Drivers arent meant to botch and give squicking noise then again it is Creative... hmmm
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...