TechSpot

Source SDK won't open.

By Envergure
Nov 16, 2007
  1. I downloaded the Source SDK via Steam and they won't open. I have Half-life 2 and Half-life 2 Deathmatch, both of which should include it.

    When I try to launch it I get the "preparing to launch" window like I should. It disappears, and nothing happens after that.
     
  2. devilsparks

    devilsparks TS Rookie

    Finaly

    I have the same problem it just says launching game then it just goes back to steam, have you solved this problem? it used to work btw but since the update it has stopped working :mad:
     
  3. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

  4. beaner

    beaner TS Rookie

    me too

    when ever i try to get in it does the same think have you figured out a way to fix it yet let me know
     
  5. beaner

    beaner TS Rookie

    it does the same for me have you figured it out yet ill let you know if i get it
     
  6. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

    Read my post, it will answer your question and should fix you problem.

    EDIT: Screw it I'll just repost it here since so many people are to lazy to click something.

    With VALVe's recent release of Orange Box good ole' Source SDK no longer works. This is because Source SDK is used to develope games that use the older version of the Source Engine (e.g. CS: Source, HL2). But wait! Source SDK is also used to develope games that use the newer version of the Source Engine (i.e. HL2: Episode 1+2, Team Fortress 2). So in the process of releasing Orange Box, the geniuses at VALVe broke Source SDK for everybody who doesn't have Orange Box or a game with the newer version of the Source Engine.

    So in this post I'm going to to tell you how to fix this problem!

    First right click the Source SDK icon, select properties. There should be something called "Target". It shold have something that looks like this there: "C: \Program Files\Valve\Steam\Steam.exe" -applaunch 211. So on the very end of this you need to add -engine ep1. This will let Source SDK let you use the newer version of the Source Engine to develope you map or mod or w.e. you are doing with Source SDK. After adding it, the Target should look more like this: "C: \Program Files\Valve\Steam\Steam.exe" -applaunch 211 -engine ep1. Hope this has helped everybody.

    P.S. If you don't want an icon on your desktop open up Steam and go to your tools tab. Right click Source SDK and choose properties. Then click "Set Launch Options" and add -engine ep1 and you should have just fixed your problem like you would have with the icon tutorial. Thanks for reading please suggest some ideas. Thanks-
     
  7. kmcglinn

    kmcglinn TS Rookie

    Hey Beef,

    Thanks a million for that, works great...you're a star!

    Kris.
     
  8. ShipMaster

    ShipMaster TS Rookie Posts: 70

    I'm puzzled why he's banned then xD.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...