Speaker/sound problem

By Cyker
Mar 6, 2007
  1. Well I just reformated about 2 hours ago, and my sound does not want to work now, I've hooked up my head phones and speakers diffrent times neither will play sound, anyone know why this is happening ? I checked the speaker website, but didnt see anything on drivers or updates, nor Have I ever had to heh, I tried useing detect new hardware with no luck and I cant open master sound control since it just keeps interupting me and telling me to check hardware and other devices and activate them, dosn't work, any suggestions ?

    Not sure what my soundcard is, Im guess it will need an update or some sort to get my dang sound back, thanks alot

  2. thetringuyen

    thetringuyen TS Rookie Posts: 22

    Hi :) I dunno much but I have this suggestion, try to open your case and see what sound card you have. If it come with your mainboard, use your mainboard disc and isntall the driver for the soundcard.. If it is an external card, try to identified the brand and series..(i never have an external soundcard before so dunno if brand and series usually write on the card or not..mine come with the mainboard) and then google for the site of the brand and look for the driver... Hope it work for you.
  3. Cyker

    Cyker TS Rookie Topic Starter Posts: 27

    Alrite well I went in and found out I have the Sound Blaster Audigy 2 Soundcard, I've had no luck looking for anything to update it or drivers for it
  4. Cyker

    Cyker TS Rookie Topic Starter Posts: 27

    I got it fixed, Thanks budy, found the drivers finally and bam I got my sound :)
  5. thetringuyen

    thetringuyen TS Rookie Posts: 22

    u welcomed ^^
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...