Speakers not using 5.1 when watching/listening to movies/music

By waterproof
Dec 11, 2011
Post New Reply
  1. My speakers are Logitech Surround Speaker Z506 and motherboard gigabyte z68x-ud5-b3.

    I havent got a soundcard but I'm wondering why i cant use 5.1? and what sort of plugins/codecs i need for it? it used to work for my old machine using realtek HD and all 5 speakers work but for some reason my newer machine doesnt work, anyone can help or lead me to find a solution?
  2. andy06shake

    andy06shake TS Guru Posts: 241

    What media player are you using and does it support Dolby 5.1?
  3. nismo91

    nismo91 TS Evangelist Posts: 899   +15

    that's weird. Z506 should upmix stereo content on its own. try to go into Realtek HD Audio control panel and activate speaker fill. it should works, although it doesnt sound good.

    i used k-lite codec packs and use media player classic to watch movies. the mpc is equipped with ffdshow audio decoder, which allows me to have Dolby ProLogic II upmix.
  4. waterproof

    waterproof TS Booster Topic Starter Posts: 207

    VLC, which should work, it has in the past with my old machine :(
  5. waterproof

    waterproof TS Booster Topic Starter Posts: 207

    Im using version 6.0 for realtek HD and don't see the speaker fill option as it should be when you launch realtek HD, maybe Im using older version?

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...