SSH- Solaris 2.8

By MattG
Oct 7, 2004
Topic Status:
Not open for further replies.
  1. Hey Everyone,

    Its been some time since i have posted on these threads.

    Only this time i am having an issue myself.

    Here is the scenario:

    A customer is trying to open one of our GUI products through SSH, and its not working. However, redisplay works fine. They would rather use SSH, due to it being "Secure". So with that said, i tried to reproduce the issue they are having...and well im pretty good at that part :)

    I type in say 'emacs' and i get no error, but emacs opens on the server box (solaris)

    I have Xforwarding set to yes in teh sshd_config in /usr/local/etc (where solaris installs SSH apprently)

    I have even tried setting X11Uselocalhost to no, and still to no avail.

    If anyone has any idea what else i can try, please let me know.

    PS- BTW on the Client side, i do have the ssh_config set up properly, and when using putty or TTERMSSH i have set the X11 Settings on there. So that isnt the issue.

    Thanks!

    -Matt
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    X forwarding must be enabled on both the client and server side. When you have logged into the server via SSH, look at the DISPLAY environment variable. Applications are displayed on the screen where this variable points to.
  3. MattG

    MattG Newcomer, in training Topic Starter Posts: 147

    Its enabled on both ends.

    DISPLAY environment can be changed with the command:

    export DISPLAY=<ip>:0.0 (or display of choice)

    When i send that, i get this error:

    Xlib: connection to "192.168.146.21:0.0" refused by server
    Xlib: Client is not authorized to connect to Server
    Error: Can't open display: 192.168.146.21:0.0

    Im assuming something is wrong on the client end now?

    Im running exceed, and SSH has X11 Forwarding enabled.
  4. MattG

    MattG Newcomer, in training Topic Starter Posts: 147

    Fixed it.

    It was Hummingbird Exceed the whole time. It was denying all Clients to connect to it.

    Works great now.

    Thanks.
  5. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    When you are tunnelling X through SSH the DISPLAY variable should be pointing to a virtual X server on the SSH sever machine. This variable is set by sshd itself when X forwarding is requested by the client.

    For example if I log in via SSH then the environment variable DISPLAY is set to "localhost:10:0". Display 10 is a virtual X server created by sshd. All requests to that server are forwarded through the encrypted SSH tunnel to my local machine.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.