TechSpot

Start -> Run... "C:\" opening a Command prompt

By jreedar
Jul 25, 2008
  1. Some how I've got my registry messed up. Now when I do 'Start' -> 'Run...' and enter 'C:\' instead of opening windows explorer at the C:\ drive it opens a DOS prompt at the that C:\ drive. I know this must be causeed by the 'DosHere' option over riding standard behavior, however if at Start' -> 'Run...' I enter a drive letter and a path like 'C:\code' then it does correctly open windows explorer at that location.

    Not a huge issue but I'd like to get it back to working as before.

    I feel like it might be related to this registry key section: HKEY_CLASSES_ROOT\Drive\shell

    Thanks,
    Neal
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    HKEY_CLASSES_ROOT\Drive\shell\find\command
    Should be:
    %SystemRoot%\Explorer.exe

    Not sure if that's it though


    Edit:

    I've changed my mind. Pretty sure it's here:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths
    Look for an entry called cmdc and remove it (probably right click ->Export first, as a backup)

    Then try Start->Run-> C: again
     
  3. jreedar

    jreedar TS Rookie Topic Starter Posts: 17

    Thanks!

    Thanks kimsland, I checked HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths and there wasn't a cmdc to remove. So next I checked HKEY_CLASSES_ROOT\Drive\shell\find\command and it was also correctly set at %SystemRoot%\Explorer.exe

    I then decided to compare the entire HKEY_CLASSES_ROOT\Drive tree with my XP pro work laptop, I found some differences and just exported the entire section and merged it with my desktop's registry to get them in sync and that fixed me!

    Just wanted to post my fix.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...