TechSpot

Strange ADSL router problem

By john w 2008
Apr 20, 2008
  1. I have had the following problems and wondered if anyone knew a fix...or the problem.

    We have a d-link 2640b adsl router/modem installed and recently our speeds became really slow. I thought someone maybe hacking the wireless and so reboot the modem and reinstalled everything. We have 1 computer connected to it via ethernet and the other by wireless.

    The speeds however are still very slow, even with the wireless pc turned off. I have gone to speedtest.net and results are poor. Interestingly, if I plug in the old usb modem supplied by the ISP, the speeds are fine, I get the usual 3.8mbps

    The problem seems to be speeds through the router. or the hardware between the router and the PC??? However, the wireless computer also has slow speeds. I have tried to run malware scanners, turned off and on firewalls and antivirus...but still seem to be having the slow speed problem when using the router. The supplied modem by tiscali on both pc's when used, gives very good speeds

    any help is appreciated!
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    First, measure/test your bandwidth on a wired link, get it right, and then fuss with the WiFi.

    Second, update the firmware on the router and the drivers for your NIC and WiFi adapter.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.