Strange FPS issue with Call Of Duty 4, driver related?

By james_k1988
Oct 30, 2009
Topic Status:
Not open for further replies.
  1. Hey there,

    I'm having a weird issue with COD4 and i'm almost out of idea's (in other words i think a reinstall may work but really cba)

    Up until recently i had a ATI 4870x2 which randomly started to get some FPS issues on COD4. I actaully made a thread about it ( http://www.techspot.com/vb/topic129790.html ), basically one day my FPS dropped and the game ran crap for a while. On single player it was almost is slow motion (not juttery, actual slow motion..) and online i got what looked like FPS lag, basically the system struggling to keep up. I didnt change anything that i know of. I eventually installed old old Catalyst drivers and it went back to normal and all was well again. I made that thread incase anyone knew why it would randomly do that

    Now however it's back! My 4870x2 died and i got 2 x HD 5850's to replace it. Unfortinately they suffer from exactly the same issue, and the downside is there arent drivers old enough to go back through to try since its a pretty new card. I've tried several drivers, reinstalled chipset drivers, turned crossfire on and off (same on both), reinstalled the game, tried different patches, updated BIOS, messed around with settings inside CCC and Google'd like a motherf***er :)

    I'm sure its somehow OS/some random configuration related due to how the issue began when i had my last card. The problem is identical, its even in the same FPS range as the old one when it done it. Its still the same install, it just seems like it'll be something really silly and will save me all that hassle. If anyone has any idea's it would be much appreciated

    I should mention i am using XP and this seems to be the only game it happens with, everything else runs brilliant
  2. mailpup

    mailpup TS Special Forces Posts: 8,277   +177

    Are you using Catalyst 9.10 driver suite?
  3. james_k1988

    james_k1988 Newcomer, in training Topic Starter Posts: 290

    I am now yes, the latest. I tried the one off the disc with this one, it was a 8.something but still didnt work :(
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.