Strange GPU problem

By Sloppy998
Jan 4, 2009
  1. Hey ppl, i have been having a strange problem the last few weeks. First off, i use my pc for watching videos and playing a game (world of warcraft).

    I am using a 9800GX2 gpu which has two DVI ports. The problem is i hook my monitor up to the DVI port at the top and i see no video whatsoever in any media player (WMP VLC etc) only a blank screen with audio, even with the latest codecs and what not. Apart from that the pc boots and acts normally and runs video games normally.

    Now i hook my monitor up to the second DVI port and the video files works fine. I can log into my online game for 10 mins or so until the monitor switches itself off and says power saving mode. Now my friend plays the same game on another computer in the house and when my monitor turns black and displays the message he says i have been kicked off the game. So im guessing the pc completely freezes even though i cant see the anything but power saving mode.

    Any help would be appreciated as this graphics card was expensive and need to know if i need a replacement or if there is something else wrong with the pc.

  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Have you installed the latest drivers for that card?
  3. Sloppy998

    Sloppy998 TS Rookie Topic Starter Posts: 31

    i have tried installing the most recent drivers and also tried wiping the pc and installing 6 month old drivers:(
  4. tengeta

    tengeta TS Enthusiast Posts: 612

    The card may be malfunctioning, see if its overheating as well.

    Could you also tell us what processor, power supply, and motherboard you are using? These could all be minor or major factors in an issue with video suddenly cutting or the entire system locking up.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...