TechSpot

Stuck on HP Invent screen

By mayday1991
Jul 9, 2008
Topic Status:
Not open for further replies.
  1. Stuck on HP Invent screen - HELP HELP

    HELP HELP HELP Please

    I have a question, I am working on a HP a1267c desktop model. The computer is stuck on the HP invent window. I will not let me into any thing. I try to use the keyboard prompts like ESC, F1 and so on. It just stays there. I have disconnected every thing on the PC. The only thing that is running is the cpu and ram. I have also tried to clear the cmos and reset it but no luck When the computer was running, I hit system restore and thats where all the problems started. It slow went downhill and this is where it end up . I have the HP manuals and tried their solution but none of them worked. The Hp manual says when clearing CMOS, you turn it on and it should come with a CHECK SUM Error, I didnt it, all i got was the hp invent screen. The pc doesnt have a floopy. Is there another way to reinstall the BIOS.

    Can some one please help me figure this out. I have run out of options
  2. Ruthe

    Ruthe TS Enthusiast Posts: 106

    Did you try F8 (repeatedly)? I'm not sure what's going on here. Did you recently install software? Are you trying to do a system restore? I may be mistaken, but I seem to remember you must start in safe mode.

    I see you added detail, but not enough. If the above doesn't work, please give details as to what you were doing just prior to the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.