Suddenly My PC Lose Connectivity With Router

By OneZ
Jul 24, 2009
Topic Status:
Not open for further replies.
  1. Hi,
    I have SMC router, i have 2 PCs connected to it, my PC sometimes suddenly lose connectivity with the router ( i can't ping the router ) while the other PC doesn't lost connectivity. The problem can sometimes be solved by just restarting my PC, but last time restarting didn't solved it, i tried uninstall and reinstall my NIC, but it didn't work, so i had to use System Restore which solved the problem. Today i had the problem again.
    I have Nod32 and Super Anti Spyware both updated, no threats found.
    My NIC is Nvidia nForce Networking Connector ( Integrated with the MB ) with the latest driver.

    Thanx....
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,746   +156

    Have you swapped the PC cable positions in the router?
  3. OneZ

    OneZ TechSpot Enthusiast Topic Starter Posts: 100

    Yes i did, i even tried a new cable..
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,746   +156

    So we know it is your computer that is causing this... But why? Are you running XP? If so, is XP updated to Service Pack 3?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.