TechSpot

Surround sounds not working

By leat
Oct 28, 2009
  1. Hi, I'm new here. Trying to find a good forum for all kinds of support to become my "Base" for questioning.

    I have a slightly different problem then others, I've read around on the web, but none has my exact problem.
    I'm running windows 7, although this can't be the problem because it's the same on the dual boot XP now.

    If I right-click the sound icon in the down right corner, choose Playback devices.
    I see several devices, only the "Speakers" are plugged in, which is correct.

    If I right-click that and choose "Configure Speakers" I come into the "Speaker Setup".
    There's two 5.1 Surround to choose, one has Side Pair, the other has Rear Pair.
    I have a Rear Pair, although they're not exactly behind me, more likely a bit on the sides because I couldn't find a place to put them.

    So I choose the Rear Pair version of the 5.1 Surround, click Test.
    Left works, Right works, Center... Can't hear nothing, Subwoofer... Can't hear nothing, Rear Left works, Rear Right works.

    Theres nothing wrong with my cables, since if I play a .mp3 file, a video, youtube video or anything else. Everything works as it should.
    Now to the real problem. If I play any game, for example... SA-MP (GTA SA), Operation Flashpoint 2: Dragon Rising, Race Driver: GRID.
    I get different problems I tend to see as a directx problem,
    might be wrong but it seems like it sends the surround sounds to the wrong speakers, or non-existant speakers.

    Ex. Grand theft auto san andreas
    I hear everything but the vehicle sounds unless I turn the view left or right because then I hear it through the left or right speakers.
    The vehicle sounds are supposed to come out of the Center speaker when I'm viewing the vehicle from behind I believe.

    Ex. Operation Flashpoint 2: Dragon Rising
    I hear much, but not all. The radio sounds (i.e commander tells you the mission), I can't hear at all, I need to have the subtitles on and read. Since the radio sound comes from the radio you have on yourself, it should come from the Center speaker.

    Ex. Race Driver: GRID
    Ohh I love this game, have everything on high, runs smooth like.. heaven. Just mad graphics and gameplay overall.
    BUT, I can't hear my own damned vehicle sounds! Unless I turn the view, just like GTA SA.
    I hear other vehicles sounds, if they're on the side, or far behind.

    My temporary solution is to plug in my PORTA PRO Headphones.
    Now I can hear everything, definitely a pain in the *** since my gf have to scream after me to come.
    Another small annoyance, I start the game and forget to plug in the Headphones.
    If I plug them in after, sounds still come through the speakers. If I minimize the game, play a .mp3 file, SOUND DOES COME FROM THE HEADPHONES.
    Mighty weird, have to restart the game. Not like that's a big problem though.



    //So if anyone could find a REAL solution for this problem, PLEASE DO.

    "Do NOT CAPITALIZE your words."

    Sorry, but I really think it fits to make things clear :/
    I'll change it if I have to, but for now I'll write...
    -caps

    Thanks.
     
  2. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    i think something is wrong with the "stereo" and "5.1 surround". although it appears that your settings are correct.

    you might open realtek hd control panel in control panel, and uncheck all : center, sub and rear.
     
  3. leat

    leat TS Rookie Topic Starter

    Okeey, I don't have realtek on windows 7 though.
    But I did that in "Speaker Setup", I hear everything now.
    So that's good, but it's not surround.
    Left, Right, Center and subwoofer works.
    No sound comes out of the Rear Pair during a game, neither playing a .mp3 file.

    BUT. Now in the test, only Left and Right is highlighted.
    Still, the Test plays a tone in Left, Right, Center, Subwoofer (well theres no bass in this tone so it's hard to hear) and the Rear Pairs.

    What next? :confused:
     
  4. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    okay when you click the rear left, the front left sounds right?

    it means realtek already assign the setup to be stereo, hence it sends the rear left to left. but, don't u think they have such bugs where in games the setup is not assigned as stereo? therefore u cannot hear some sounds...

    so since everything is not clear, how about trying plug your speaker to rear jack for an example and try playing games with same realtek settings?
     
  5. leat

    leat TS Rookie Topic Starter

    Actually, when I click Rear Left in the Test thing, it comes from Rear Left, same with all. Everything works in the Test.
    To get "surround" or more likely sounds from all speakers (i.e getting Rear Pair to work when playing a .mp3 file).
    I have to check the checkbox called "Speaker Fill" in Enhancements.
    Currently, Test mode is working, playing music and playing video works as it should (although I'm not sure with video, but sounds do come out of all speakers, sounds that don't come out of Left, Right, and Center, comes out of the Rear Pair).

    But still no results while gaming. :(
    I can choose between making ALL sounds come out of Left, Right, Center and Subwoofer (i.e Stereo I believe).
    Or having surround sound with a few sounds missing.

    I don't want any of those, so I'm still using my headphones. :(
    Why can't it just work as I want it to. :evil:

    And I do have them plugged in, in the rear.
    I have a Green (L - R), a Orange (C - Sub) and a Black (RL - RR), all plugged into the Rear Panel.

    Further help?
     
  6. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    as far as i know you should set it so that all sounds come out from 2 speakers instead of few sounds missing... im not sure...wait from others.

    so when u plug your speakers / headphone in the rear jack while gaming, any sound?
     
  7. leat

    leat TS Rookie Topic Starter

    I'm not exactly sure what you mean with that, but if I plug my headphones in while in a game,
    sound still comes out of the speakers, I have to restart the game for the sound to come out of the headphones.

    That's not a big problem though, I'd like to prioritize getting surround sound in games to work. :)
     
  8. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    what i mean is...
    you;re using headphones only right? and when playing games, u did not hear some of the sounds?

    so, in games, how about plugging your headphones to the "rear jack" plug instead of the normal "front jack" plug... if there is sound, it means your realtek setting has some bugs...
     
  9. leat

    leat TS Rookie Topic Starter

    I do hear all sounds with headphones while playing a game, my headphones works perfect.
    Only I want to use my surround sound speakers (5.1), not my headphones.

    But do you mean... Plugging the headphones into the rear jack and see if I can't hear some sounds?
    I don't think I have a jack for headphones on the rear on my pc though.
     
  10. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    oh sorry, i misunderstood the first post.. so the problems is on your 5.1 speakers? not the headphones? my bad...

    your first post mentioned u cant hear the centre and sub working.. does it still persist? it looks like the settings are mismatched. or either there are something wrong with the config (e.g. i heard rear left in rear right in movies only because i set decoder to rear, not side).

    any picture of the realtek control panel screen?
     
  11. leat

    leat TS Rookie Topic Starter

    While playing a game, the surround sounds not working basically.
    If theres something on the side of me, I hear it from the side. That works fine.
    But if theres something infront, or behind. I can't hear it.
    If i test with a surround sound "checker", with a sound going around.
    I hear it from behind, to the side, and then it stops in the middle, then continues on the other side.

    And in the test panel, all except the Center and Subwoofer makes a sound.
    But when I uncheck the Rear Pair, Center and the Subwoofer. It comes a sound from all speakers in the test panel.
    But still no result in a game...

    Btw, I still don't use realtek panel.
    Windows 7's sound panel has almost the same options as the realtek panel though.
     
  12. nismo91

    nismo91 TS Evangelist Posts: 900   +15

    i believe the 7 windows panel should be somehow similar to vista isnt it? (from screenshots)
    whatever the case is, there is something wrong with your realtek.

    one example is that i "outdated" my realtek driver, otherwise i have chopped mic sound on skype. mayb you'd like to check that one out as well. and for the vista sound panel, in 5.1 i cannot check the "rear-pair" because it is meant for 7.1
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...