TechSpot

Suspected DHCP issues preventing Internet access

By Robertyne
Sep 14, 2010
Post New Reply
  1. Well. My Desktop crashed earlier today, and upon rebooting was unable to connect to the internet (my Network Connections tells me that it has 'Limited or no connectivity'). Upon running the Network Diagnostics I am told my DHCP Server has an invalid IP address, and after reading other posts on these boards it appears that the IP address displayed is only there because Windows automatically assigned it due to an inability to obtain a real one (169.254.242.96). My router is working fine, as I am using at this very moment to post this topic on a friend's laptop, but for reference it is a Netgear VMDG280 supplied by Virgin Media.

    After spending a few hours trying to find out what is wrong I have a feeling it is my computer's inability to contact the DHCP server that is preventing it from being assigned an IP address, but I have no idea how to remedy this.

    I am running Windows XP Professional, Service Pack 3.
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    you are correct - - the DHCP address should be the same as the router address.

    Start with the obvious
    1. make sure your TCP does not have a static DHCP or DNS address defined
    2. then ensure your router is still offering DHCP (ie is enabled) and has a range of addresses to offer (eg 2-32)
    Then disconnect the system from the router; wait 30 seconds and reconnect

    After another 30 seconds, get a command prompt and enter
    ipconfig /all
    and post your findings in the follow-up . . .
     
  3. Robertyne

    Robertyne TS Rookie Topic Starter

    That's what it gave me. Thanks for the help, by the way.
     
  4. hughva

    hughva TS Rookie Posts: 309

    Try a different Ethernet cable.
    Try a different router port.
    In Device manager, uninstall the Ethernet adapter and reboot to reinstall.
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    You need Hybrid

    Code:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NetBT\Parameters\NodeType RegDword = 8
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\NetBT\Parameters\NodeType RegDword = 8
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\NodeType RegDword = 8
    you will need to reboot to make it effective and then ipconfig /all will show
    Node Type . . . . . . . . . . . . : Hybrid​
    and find the DHCP server :)
     
  6. Robertyne

    Robertyne TS Rookie Topic Starter

    I've looked for these bits in the registry editor, but none of them seem to show up. Does this mean I'll have to add them manually?

    EDIT: I added them into the relevant registry categories (ControlSet002 didn't have the NetBT directory in Services, but ControlSet003 did so I added it there instead) and ipconfig does indeed show the Node Type as 'Hybrid' now. However, the problem hasn't changed and it is still unable to find the DHCP server.
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    make sure the router is enabled for DHCP
     
  8. Robertyne

    Robertyne TS Rookie Topic Starter

    Aye, it is. My subnet mask above is 255.255.0.0, whereas on the router's information window the WAN Subnet Mask is listed as 255.255.252.0. Is this relevant at all, and is it something I'll have to change manually?
     
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,373   +167

    If i may add some info....

    1. Very most often, one only need perform regedits on HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet (ignore the other CurrentControlSet keys)

    > CurrentControlSet is exactly what its name implies: it's the current configuration you;re running under that needs "tweaking"
    > CurrentControlSetnn are PAST configurations you've run under and Windows saves for "fallback" use (e.g. When you reboot Windows to "Last Known Good Configuartion" Windows loads one of these past configs. One typically needn't edit these as only under special situations will they ever be used. PLUS each one is eventually overwritten and replaced each time you (or Windows) creates a NEW ControlSet configuration

    2. I'd also suggest you might try uninstalling then reinstalling your network driver
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    strange.
    You're saying that when viewing the Router's configuration for DHCP it shows
    • a dhcp range (something line 2-23)
    • a mask 255.255.255.0
    • and the routers address
    but when you get an address, the mask goes to 255.255.0.0?? likely an issue going with the 169.x.x.x problem.

    What firewall are you running? Make sure you
    allow in/out src=any dst=any ports 67-68 UDP ​
    and push it to the top of the list of rules
     
  11. Robertyne

    Robertyne TS Rookie Topic Starter

    Yeah, ipconfig is constantly showing my Mask as being different from that of my router. There's a wide range of adresses available on the router and none of the other computers in this house have any trouble connecting. My firewall is currently disabled while I've been fixing this too.

    I've uninstalled and re-installed the network drivers and the problem persists. For convenience, I'll paste what my router's information says below:

    LAN IP Address: 192.168.0.1

    Subnet Mask: 255.255.255.0

    DHCP Server: Yes

    Starting IP Address: 192.168.0.2

    Ending IP Address: 192.168.0.254

    I ran ipconfig again just to check and it still says the Subnet Mask is 255.255.0.0. I guess this is the root of the problem?

     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    No, it's a side-effect. 255.255.0.0 is still valid, just different.

    Restart your firewall - - many have goofy results when disabled, including total network shutdown.
     
  13. Robertyne

    Robertyne TS Rookie Topic Starter

    The firewall (Sophos Client Firewall) has been re-started and I've reset the exception rules. Unfortunately, the problem is the same.

    When I get it to detect Local Area Networks to which I am connected, all it returns is the 169.xx.xx.xx address, as if this was the address of the router.
     
  14. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    RESET? you need to allow ports 67-68 one way or the other.

    169.xx.xx.xx is your pc address, not the router
     
  15. Robertyne

    Robertyne TS Rookie Topic Starter

    Well, this is bizarre. I took the side off my computer and was messing around with my RAM sticks to fix another issue I had with my hardware. Upon putting them back in and re-starting the computer the internet is working perfectly, as if nothing had been wrong...

    I haven't the faintest clue why. Still, it's alright now. Thanks ever so much for the help you've given me. It's really appreciated ^_^
     
  16. jobeard

    jobeard TS Ambassador Posts: 13,446   +323

    coincidental and not the cause :) - - but then who cares if it's working now.

    if the router was powered off during the exercise, then it was (imo) the rebooting of that device.

    thanks for the feedback.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.