TechSpot

System won't boot (Ubuntu server 12)

By marinkvasina
May 25, 2013
Post New Reply
  1. I don't know if this is the right section, I can't seem to find one though.
    Anyways, I have got hold of an old system these are the specifications:
    Intel Pentium 4 CPU 2.80 GHz
    Asus P4P800-VM
    Seagate Barracuda 7200.7
    2x Infineon 256MB DDR RAM (Samsung Pc2700U-25331-A1 256 DDR RAM)

    So I installed an Ubuntu server onto that, it worked for a few days or so then one day when I was trying to boot it, it wouldn't work. All I got was this screen (after the Ubuntu boot loader): http://imgur.com/tcV093C
    I was suspecting the RAM (system is very very old..), so I ran the memtest (option on boot loader) and well the modules failed it.
    Then I got this 1 RAM stick from a friend (passed memtest just to be safe), and I still get the same screen.
    What could be causing this, since I have never experienced such a problem before?
  2. mike1959

    mike1959 TS Addict Posts: 1,060   +19

    Hi, From your photo it looks like a hard drive failure.
    But if the pc is very old or unknown to you, I would check if the BIOS battery is ok, or it will keep going back to default settings, if the battery is low or flat.
    But it would be worth swapping the hard drive for a known good one just to prove the point.
    If you can get into the BIOS, make the first boot device to be the CD/DVD drive, save the settings and exit.
    Then if you have a Linux distro on cd that will run as 'live', (say from a 'Linux User' mag coverdisc), reboot the pc with that cd in the drive, then let it go to the desktop, then use the install icon to install the O/S to the hard drive.
    If the RAM is faulty you won't get past the power on self-test (POST) and you will get warning 'beeps' (if the pc has a speaker module inside).
    Hope that helps !
  3. marinkvasina

    marinkvasina TS Enthusiast Topic Starter Posts: 259   +9

    I tried the HDD, connected it to my main PC and it got past that screen, to the login one. How do I check the BIOS battery (I kinda don't have the time to google it right now, will do later/tommorow). I have an Ubuntu server cd, I can make the linux one if neccesary.
    Well I got to the bootloader, opened memtest there, the RAM didn't pass it but oh well might not be the problem there.
  4. mike1959

    mike1959 TS Addict Posts: 1,060   +19

    Hi, Ok, sounds like the HDD is working. The BIOS batteries are 3V when new and should be good for 4 to 5 years. You can check them on a multi-meter tester set on DC volts, or a battery tester on the 3V range. The second one is better as it puts the battery under a load, where the voltage will fall to a more realistic level, as in use.
    A low battery won't stop the pc from working, but will mean BIOS adjustments by you won't be saved.
    A low battery voltage would be about 2.0 Volts (roughly). But even without a tester you would know as the changes you make in BIOS then save, will go back to default, every time you reboot, or next time you switch the pc on.
    If you have RAM module faults, it won't get beyond the first 'on screen' POST, so the Linux O/S won't be loaded.
    Linux will run on a very low spec pc, if you can find a good 256MB it should boot & run, I would have thought. I have used 512MB.
    I have a spare pc running Linux Mint 14, and Ubuntu 12.04, both run well.
  5. marinkvasina

    marinkvasina TS Enthusiast Topic Starter Posts: 259   +9

    Then I don't know what the problem is. I get beyond the first 'on screen' POST, and get stuck after choosing Ubuntu server, it just doesn't load.It's a weird problem which I haven't encountered before.
  6. Leeky

    Leeky TS Evangelist Posts: 4,378   +98

    It could be any number of software related problems, assuming your hardware is fine. In my earlier days of using Linux I came across this issue when changing RAM on a couple of occasions.

    I never did narrow down what the issue was, but I did find wiping it and do a fresh installation usually solved the problem very quickly. You can reuse your existing partitions and just mount /home (rather than format as well) to keep your local files.
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,525   +300

    I think the settings will remain with a dead battery as long as the computer remains plugged into the mains and there are no power interruptions. So a crude test would be to unplug it from the wall, hit the power button on the pc. Then plug it back in and boot up.

    Only really bad RAM won't make it past POST. Most RAM issues show up as system boot problems, OS instability, and/or memtest failures. If all bad RAM prevented getting past POST then there would be no use for memtest.
  8. marinkvasina

    marinkvasina TS Enthusiast Topic Starter Posts: 259   +9

    It was unplugged at the time where the first 2 RAM sticks were broken, I got a spare one, pluged the system again, ran memtest, it passed.. then I came across the same problem.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.