System32.exe Virus

By ejcsue
Mar 1, 2006
  1. I ran AVG virus scan and it showed that I had a few virus' that attched themselves to the System32 file. (for example System32\msblast.exe)

    The AVG I had did not have the option to clean all of these files so I deleted them. Out of the recycle bin and everything.

    After this I noticed that I cannot access the internet.

    I called my ISP who shows that they see my modem but for some reason it is not pulling an IP address.

    1.) Is the fact that I deleted these files causing this error?
    2.) If so, what can I do to recover or install the System32 files that I need to get back up and running on the internet?

    I will try anything. I am one step away from reformating my computer.
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

  3. ejcsue

    ejcsue TS Rookie Topic Starter

    System32 Virus

    Thank you Didou. I will give it a shot.

    Thanks for the quick responce.
  4. ejcsue

    ejcsue TS Rookie Topic Starter

    System23 Virus


    I ran the winsocfix but I still cannot access the internet. I keep getting the same Microsoft Update pop up on my screen for the Cumlative Security Update for Outlook Express 6. It says I am downloading it and installing it but it keeps popping up.

    Do I need to configure anything?
  5. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Have you checked to see if you get an IP from your isp ?
  6. Evalds

    Evalds TS Rookie

    just reinstal windows :knock:

    ...and no problem
  7. peepnklown

    peepnklown TS Rookie Posts: 126

    Did you happen to run AVG in SAFE-MODE?
    If you are running Windows XP you might want to try SFC
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...