TechSpot

system32\hal.dll. problem with Raid

By swimsalot
Mar 29, 2006
  1. Thanks for any help!
    Specs are:
    AMD64 3000
    Gygabyte K8N-Pro
    2B Pc3200 Crucial
    2X 80B Western Digital SATA Hard Drives in RAID Zero
    Radeon 9800 Pro
    windows XP home SP2
    no overclocks, a few extra fans.

    I get the missing or corrupt file error when booting, <windows root>\system32\hal.dll.
    -I tried to boot from the XP CD to repair it, but if still gives same error.
    -I changed BIOS to boot from CD-ROM first. When it comes to prompt for hit any key to boot from CD I do so, still get same error message.
    I think the problem is that the system is not recognizing my RAID 0, so it doesn't see any drives on the system.
    I can't get to the screen in repair mode that asks you to "press F6" to enter RAID setup.
    I Google'd the error but all the fixes talk about using the CD to repair the problem, since I can't do that I need further help.
    I downloaded a NTSF.boot disk from Bootdisk.com, but I don't think I have enough knowledge to mess around with that stuff.
    Anyone have any ideas on how to get the system to recognize my hard drives? I think there is a way to change the boot order in BIOS to recognize the RAID first, but I don't know how.
    Thanks in advance for the help...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...