TechSpot

Task Manager will not open

By BeeGee
Jun 23, 2009
  1. I'm not quite sure how long I've had this problem, as I don't often have to use Task Manager. But I've found myself unable to activate the program at all, using any of the shortcuts. I might be worrying over nothing, but I have heard this sort of thing is an under-handed and dirty trick used by some viruses and malware. I scanned my PC with AVG and Spybot-SD, with no luck. But to be honest, I'm none too sure about this sort of thing.

    I've also been through the 8 steps to get the ball rolling, as suggested. No luck so far though, Task Manager still won't activate. Hopefully one of you gents will be able to make something of these logs that the guide requests I post, though.

    If there is anything I should be doing to keep my PC safe from this sort of nonsense that I'm not doing, please don't think you're being rude by pointing out any silly mistakes I've made. You'd be doing me a grand favour.

    My thanks in advance.
     
  2. ChrisDown

    ChrisDown TS Rookie Posts: 125

    The HJT log looks clean to me, SAS and MBAM seem to have done their job in removing the malware.

    To get task manager re-enabled, open notepad, and copy the following:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
    "DisableTaskMgr"=dword:00000000
    
    Save it as task.reg, then double click it to open it. It will ask if you want to add the data to the registry, click yes, and it should be working again. :)
     
  3. tystanwick

    tystanwick TS Rookie Posts: 29

    I agree with Chris...HJT looks cleans and MBAM/SAS only found minor adware.

    To fix the no task manager issue go to start then run (windows XP) or in the search line for vista....or just use the shortcut windows key + R. Copy and paste the following into the run command then hit enter:

    REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableTaskMgr /t REG_DWORD /d 0 /f

    press crtl+shift+esc......task manager should be back.
     
  4. BeeGee

    BeeGee TS Rookie Topic Starter

    I'm sorry to say that neither of these actions seem to have done the trick, regarding getting Task Manager going again. Anything else I could try, or that the problem might be?
     
  5. tystanwick

    tystanwick TS Rookie Posts: 29

    Its possible that SpyBots TeaTimer is keeping you from making changes to the registry. Try disabling teatimer from spybots GUI, or go back to HJT, put a check next to this then hit fix:

    O4 - HKCU\..\Run: [SpybotSD TeaTimer] C:\Program Files\Spybot - Search & Destroy\TeaTimer.exe

    If teatimer comes up and asks you if you want to allow the changes, click yes (or allow, whatever it says, just agree with it.)

    Then try the above again.
     
  6. aqua

    aqua TS Rookie Posts: 57

    browsing found this,,hope it helps...

    Click Start -> Run. Type in "regedit" (no quotes) and hit Enter.

    Search for HKEY_CURRENT_USER -> Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ System.

    Look for: DisableTaskMgr. Click on REG_DWORD. Value: 1=Enable this key (disables TaskManager); Value: 0=Disable (actually enables TaskManager)

    Close RegEdit

    Reboot your machine.
    ....................................................................................................
    also read this...
    I got same pronlem and I got temparory solution--Install -->http://www.microsoft.com/technet/sys...sExplorer.mspx

    and delete red coloured processes. It will kill all virus processes which were to max your cpu uses and make Task manager essential. When these virus processes will no longer be running, you will definitely get task manger .
    ..............................................................

    Try This one

    http://www.dougknox.com/xp/utils/xp_taskmgrenab.htm

    ................................................................................

    Click Start -> Run. Type in "regedit" (no quotes) and hit Enter.

    Search for HKEY_CURRENT_USER -> Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ System.

    Look for: DisableTaskMgr. Click on REG_DWORD. Value: 1=Enable this key (disables TaskManager); Value: 0=Disable (actually enables TaskManager)

    Close RegEdit

    Reboot your machine.
    ................................................................................

    HOPE ANY OF THIS HELPS.................
     
  7. BeeGee

    BeeGee TS Rookie Topic Starter

    Still no luck, I'm afraid. One notable change is now that when I try to activate Task Manager, my cursor no longer indicates that something is loading for a few seconds.

    EDIT: Ah, just seen the new post. Will try that.

    EDIT 2: Still no luck in the slightest.
     
  8. ChrisDown

    ChrisDown TS Rookie Posts: 125

    Does no message appear at all? Usually 'Task Manager has been disabled by your administrator' will appear.
     
  9. BeeGee

    BeeGee TS Rookie Topic Starter

    Not at all. I am the sole user of this PC, and as such am the "administrator" myself.

    However, I've just noticed that if I directly activate the taskmgr.exe in RECOVERY (D:) rather than OS (C:), it works. But I have no idea what means, and what I should do about it.
     
  10. ChrisDown

    ChrisDown TS Rookie Posts: 125

    That message is referring to a literal 'administrator', not just the permissions assigned to the user accounts. :)

    Have you tried copying taskmgr.exe across from D: to C:?
     
  11. BeeGee

    BeeGee TS Rookie Topic Starter

    An error message is telling me "Destination Folder Access Denied", and that I require permission to perform this action. We've come this far, could you perhaps enlighten me as to the best way of telling my PC to sit down, shut up and do what it's told?

    Hopefully this will be the final hurdle in solving this little problem.
     
  12. ChrisDown

    ChrisDown TS Rookie Posts: 125

    Running blind here (since I haven't been on a Vista PC for yonks), but from what I have read elsewhere, right click on the Windows folder in c:\, select properties, select sharing, select 'full control'.

    I'm still working on that one myself ;)

    EDIT: Matt, a friend of mine, just sent me over a screenshot of the security tab on his machine. Looks like you have to select 'Administrators', then 'edit', then allow all by selecting 'full control'.
     
  13. BeeGee

    BeeGee TS Rookie Topic Starter

    When I try to make THIS change, I am being told that "access is denied". This is becoming quite ridiculous.
     
  14. ChrisDown

    ChrisDown TS Rookie Posts: 125

    Either this is Windows doing what it does best, or there actually is some malware to be found somewhere. That said, if this is all that is happening, I'd be doubtful that malware actually is the problem.

    I have very little in the way of ideas for this situation. I wouldn't have thought that UAC would cause this (IIRC, correct me if I'm wrong), but maybe temporarily disabling UAC and having a shot might yield results. Sorry, this really is a wild stab in the dark, but I've had some success with such stabs previously. ;)

    Try this:

    1. Go to Start > Run > type 'msconfig' without the quotes
    2. Go onto the tools tab, and click 'disable UAP', then click launch.
    3. Once this is done, close msconfig and restart.

    After that, try again. If that doesn't work, then I think I might well be stumped.

    To re-enable UAC afterwards, do the same, but click 'enable UAP' instead.
     
  15. BeeGee

    BeeGee TS Rookie Topic Starter

    Yes, well, I've had User Account Control switched off this entire time I've been trying to sort this out, unfortunetly.
     
  16. ChrisDown

    ChrisDown TS Rookie Posts: 125

    I'm utterly stumped by this one, then. I'll do some asking around.
     
  17. BeeGee

    BeeGee TS Rookie Topic Starter

    We are back to square 1. I managed to replace the original taskmgr.exe with the version that was working. But when activated from the original folder, it once again ceases to work.
     
  18. ChrisDown

    ChrisDown TS Rookie Posts: 125

    I would have suggested the system file checker, but if it is working elsewhere, then that is not going to help.

    This seems similar, perhaps unresolved. Have you done any system tweaks (especially in the area of services) since you installed the OS?
     
  19. BeeGee

    BeeGee TS Rookie Topic Starter

    I might as well try it, it can't hurt and we seem to have exhausted quite a few solutions already.

    I can't say I'm done any "tweaks". System-wise all I do is have the computer regularly install it's updates.
     
  20. nofirst

    nofirst TS Rookie

    Introducing another victim.. that is.. "Me" :)

    Hello experts,
    I'm also having the same problem with BeeGee here:
    Task Manager won't opens, and for sure this is not a simple "Task Manager has been disabled by Administrator" problems.
    As stated by BeeGee, no dialogs error poped-up.
    gpedit.msc, reg.exe, and other similar method might not help.

    And i would like to add some information:
    - there is a notification beep sound from windows system and nothing got out when I attempt to open task manager in many ways.
    - I've tried to run "taskmgr.exe" from console C:> and it says Access Is Denied
    - taskmgr.exe run well in safemode

    I was using Avira Antivirus and found no threats. Recently I swicthed to lates AVG and caught a virus here:
    "C:\Documents and Settings\All Users\Application Data\SecTaskMan\_csrss12181800" ; "Virus found Lop" ; "Moved to Virus Vault"
    Too early I thought I've found the solution, yes, the task manager attempt to start on the next reboot after i sent that virus to vault. But not for the second time , things got back to normal after then.
    this is actually a wierd behaviour of taskmgr.exe (or virus somewhere).. hope this information should helps.
    I've been trying this utilities in latest update:
    -Super AntiSpyware
    -Malwarebytes Anti-Malware
    -HijackThis and found nothing suspicous.

    @BeeGee, this problem doesn't slows our computer right? Yet it doesn't behave like malware that sends information to outside (I'm protected with Online Armor and don't sense any threat, but actually i doubt :) ). If I might suggest you use ProcessExplorer instead of ordinary taskmgr.exe, I'm on it now ... temporarily and stop complaining my problem :). Good Luck while we're still helpless.
     
  21. nofirst

    nofirst TS Rookie

    oh, and btw,
    even though I'm also not quite sure when is it precisely this problem begins.
    i give a few hint that i recently installed these programs from FileHippo
    -Piriform Defragler
    -Piriform Recuva
    -MyDefrag

    that's all additional information.. hope to hear a solution soon .. thanks in advance.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...