Tcpip.sys 0x0000007E

By GadiK
Dec 16, 2007
  1. Hi, I've installed a pacth for inlarging the number of halfports (it supposed to make file sharing fatser) form "". It worked great for a couple of days but then the computer started freezing up and giving blue screens.

    Now, I should mention it started after I installed a device for the phone line.
    This device is like a router it connects to my cable modem and then a network cable connects it to the computer and a phone cable connects it to my phone. This device is from my IPS, and keeps my internet connection always on.

    Sometimes when I open "utorrent" i get a warning in the event viewer (windows xp) that says: "TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts."

    And after some time (it varies from few minutes to a whole hour) the computer freezes. After I restart it I get the Save Dump message that says: "The computer has rebooted from a bugcheck. The bugcheck was: 0x1000007e (0xc0000005, 0xf440f5c8, 0xf6af6b20, 0xf6af681c). A dump was saved in: C:\WINDOWS\Minidump\Mini121607-01.dmp."

    I've already removed my NIC driver and reinstalled it, didn't help.

    I'm attaching 5 dumpfiles in a zip, please HELP..............
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Either failure due to the device you mentioned, memory failure, infestation or power supply. Try removing everything that is not critical to operation and see what you get while running on a minimum install.
    To rule out memory, run MemTest86 for four hours or seven passes, if you can.
    When you come back, give us the brand and model of your computer and power supply.
  3. GadiK

    GadiK TS Rookie Topic Starter

    My computer is Core 2 Duo E6750 running on a Gigabyte p31 mobo with 1Giga memory. I have thermaltake 420W powersupply and if it's any importance nVidia 6600 graphics card.

    Where do i get MemTest86? and can i run other programs while running the diagnostics?
  4. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    See if you can update Netlimiter.
  5. raybay

    raybay TS Evangelist Posts: 7,241   +9

    If I were a betting man, I would bet on that Thermaltake 420 power supply... It is getting long in the tooth... and though it has a great name, it is not close to the best setup for what you probably need, particularly if you have a TV, and other electrical power hogs on the same circuits..
  6. GadiK

    GadiK TS Rookie Topic Starter

    Okay guys here are some things that i've noticed.
    Almost every time I launch utorrent I get an error in the Event Viewer
    Event ID: 4226
    TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.

    I checked in the utorrent Pprefrences->Advanced->net.max_halfopen and it's 8 (I removed the patch and my half ports are now configured to 10).
    I ran the next command in the command prompt: netstat -no | find "SYN"
    and it gave me a list of 14 ports all being used by utorrents PID (the PID i got form the Task Manager).

    I changed the net.max_halfopen to 6 and the "netstat" command gave me the same result of 14 ports assigned to utorrent.

    Has anyone dealt with this problem before?
  7. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  8. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    Are you sure you applied the Tcpip.sys patch correctly? I had to apply it in safe mode. This should set the half-open allowable to 50. Setting it to 50 removed Event ID: 4226 for me.
  9. GadiK

    GadiK TS Rookie Topic Starter

    to Blind Dragon, I've already installed this patcher before then removed it.
    Now I've reinstalled it and set the number of ports to 50.

    to peterdiva, I didn't upply it in safe mode, however it gave me the impression that the installation (or patching) was successful
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...