TechSpot

The Dreaded AUTOCHK.EXE not found

By ktkt2006
May 13, 2008
  1. Hi - I am pretty sure I know what this is - installed a windows update and then had a crash in the middle, now I get the error:

    autochk program not found skipping AUTOCHECK

    Even when booting into safe mode. The good news is, I DID create the recovery tools cd, so I can get to the recovery console, the bad news is, I can't get PTEDIT to run from DOS. PTEDIT is actually in the root drive, I just can't get it to run.

    Any other solutions? I see a lot of comments about booting from a floppy... I don't have a floppy drive...
     
  2. xxdanielxx

    xxdanielxx TS Rookie Posts: 1,214

    hey try this

    First question. Do you happen to have your Windows XP cd? Hopefully, because you're going to need it to fix this problem. If you have it then try the following:

    Using your XP installation CD, boot to the Recovery Console

    When you get to the command prompt window, type the following
    commands:

    chkntfs /x c:
    There is a space before and after /x
    This cancels the checkdsk on drive C:

    Next, type this command

    Copy E:\i386\autochk.exe C:\Windows\System32\

    Where E: is the drive letter of your CD drive. Change this for your system.

    Here is a microsoft site on how to get into the recovery console.

    http://support.microsoft.com/kb/307654

    Let me know how things go.
     
  3. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    Hi - Thank you for the reply!

    I do have my cds - and I can boot to the recovery console. This is where I run into issues - I am presented with three options:

    1 c:\I386
    2 c:\MiniNT
    3: i:\WINDOWS

    The first two put me in those directories, and I can't CD out of them.

    The last one prompts me for the password (I don't know the password, it isn't my windows login)
     
  4. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    OK I am in the recovery console and was able to get to windows, but it looks like chkntfs isn't a valid command in the recovery console - there's a whole list on the MS link you sent.

    Am going to try copying the PTEDIT file again.
     
  5. xxdanielxx

    xxdanielxx TS Rookie Posts: 1,214

  6. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    was able to get into windows drive (no password! - no wonder i didn't know it) only problem is the recovery console appears to use different commands - typical cd and chkntfs won't work.

    Found your solution on the MS site as well - will try copying the file from the recovery CD and see what happens.
     
  7. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    Hi - I did the above and am still having the same issue - the file is there, I think the drive is hidden.

    I am hoping I can fix this with PTEDIT but I can't figure out how to get to DOS. Is there an easy way to get to a DOS prompt (not the recovery console) from the bootable Win XP CD? Don't have a floppy drive...
     
  8. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    Still need help...

    Hi - I have tried the suggestions here and nothing has worked - I was able to create a boot disk to get to PTEDIT but that didn't work either...

    Was never able to get chkntfs to work to turn off the autochk - anyone know how to do that from the recovery console?
     
  9. xxdanielxx

    xxdanielxx TS Rookie Posts: 1,214

    what do you mean you think the file is there but the drive is hidden. Didi it give you an error when trying to copy the file

    If you feel you can work in the registry you can edit it manually

    Open Regedit and modify this (if absent): go to strat>run and type regedit then go to

    HKEY_LOCAL_MACHINE\SYSTEM\
    CurrentControlSet\Control\Session Manager
    AutoChkTimeOut
    DWORD = 0

    Or modify this if the value is different:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\
    BootExecute
    REG_Multi_SZ = autocheck autochk *
     
  10. ktkt2006

    ktkt2006 TS Rookie Topic Starter

    Hi - the file is definitely there, and I have copied it from the system restore disks as well. I think the drive is hidden, based on previous threads in this board and others.

    I can't get into windows - so no start menu. Can I get to regedit from system recovery?
     
  11. xxdanielxx

    xxdanielxx TS Rookie Posts: 1,214

    try hitting the f8 key at startup to see if you can boot to safe mode
     
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.