TechSpot

Thinkpad 765L reformatted C: no CD drive

By longhairlaw
Jul 10, 2007
Topic Status:
Not open for further replies.
  1. Who: A curious little grey haired ol lady with what seems to have been a common situation back when but woe, the solution is elusive today.
    What: Thinkpad 765L made for W95, upgraded to 98SE (more mem, etc.), everything worked fine.
    When: Few months ago installed XP, too much program, (for the little grey haired ol lady - not the Thinkpad), and without XP experience, no more internet connection, and peripherials failed
    Where: Not only uninstalled the XP but the W98 also so reformatted and sys'd the C: and with that everything went into utter outer space.
    How? Asking myself the same question. Got another boot disk (floppy) for W98 and it tried to load but W98 OS was gone! without an OS . . . so, went back to kinder garden and DOS floppys for DOS 6 but DOS 7 is still recognized. (Don't have floppys for DOS 7 any longer nor the box of em for W98.) Thinkin' meybe root dir? How do I get into that?
    Now: Still only floppy drive works. Boot prompt is asking for boot disk #2. Two? there was only ever one! Still, CD drive isn't being recognized, never was after the launch. (what is black hole in techy slang?) And have tried with cold boot, warm boot, hot exchange of the floppy and the CD, cold exchange (that's hooey because turning off sends the invisible E: RAM drive into gone too) Also copied all files to C:, changed config to boot from hd first, changed the a: to a c: , rewrote both config and autoexec so many times I may have done some permanent damage. My boss lent me a computer. Guess what it is? An IBM Thinkpad T30. No floppy, only CD. I have cables. I hooked up the LPT1, the COM1 and only the COM1 could be configured but there is no phone line and the 765L has no USB. I have a card in the 765L which accepts the (T1=fat phone line) but only one outlet on the T30 so splitting isn't an option.
    So: Came here to where someone knows why curiosity killed the cat.
    Please: reply to me with the line by line config.sys and autoexec.bat with the line for the cd driver; and, how do I get a DOS prompt back instead of the "..disk#2" message?
    Can: I cable them together? What would the settings be in XP on the T30? This is a request, not of curiosity but desperation. I promised not to touch the settings on the T30 (hehe) But I have figured out the XP thing so I'd just put the XP back on the 765L. I do have the licenses for all three OS's.
    Just goes to show if one shoulda, coulda, or woulda, the result is dooda. (That's doo doo in Techy slang.) Tragic, isn't it.
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    First. Does the BIOS recognise the CD drive? Go to BIOS setup and see if it is listed. If it's not, then you have a hardware problem.

    Second, does the DOS bootable floppy actually have CD-ROM drivers on it? Download the custom Win98SE boot floppy from www.bootdisk.com.
  3. longhairlaw

    longhairlaw TS Rookie Topic Starter

    Thank You for reply (and taking time to wade through my post).
    Couldn't find standard BIOS as Thinkpad 765L has only the introductory window for Test, Config (Boot sequence), Time & Date, etc. There isn't an official BIOS that one can access by pressing DELETE upon boot or startup. If there IS a way to access the BIOS, I would appreciate the HOW TO. That way I could attempt another fix. This is a seemingly old problem with reformatting the Thinkpad older versions. I have not been able to access any information as technology has progressed so far from W98. As a last-ditch effort I'd prefer to link and had a link program in 1997 so I know it must exist though now is called home networking. I'm researching it now. I've tried a few methods to no avail. I'm happy not to be dealing with W3.1 though, Again TY
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Like many other older ThinkPads you hold F1, power on the system and keep holding F1 until you get to the diagnostics screen (or the beeper starts complaining about a key held down).

    (Quite amazingly, you could have learned this from the manual)
  5. longhairlaw

    longhairlaw TS Rookie Topic Starter

    t

    I have and have read the manual :). That's why I've posted here, with all the smart (people). There is no Operating System - I reformatted it. Yes the F1 key brings up the configuration window but it is limited to CONFIGURATION, DATE/TIME, PASSWORD, START UP (boot order), TEST, and RESTART. There isn't access to the BIOS such as any other computer I've ever used. I had the boot disk for W98SE and because there is no OS, I'm sort of SOL. The CD won't run or I'd be able to use my CD's to reinstall everything. I have the licenses and manuals for those also. I've also gone to the library and have or had the *****'s guide for laptops, PC's, reinstallation, fixing, and such (tho none for which can it goes into in California, recycle, green waste, or garbage). I am on a borrowed computer now. Also a Thinkpad running XP. No floppy other than the CD drive. I have cables, I'm researching cabling them together but instructions are telling me to open certain windows on each computer, not how-to without an OS on one. I was hoping someone could line by line, write the config.sys and autoexec.bat for me to try with a clean configuration and load the CD drive, but now I can't get past the prompt for boot disk #2. I only ever had one disk. I also had a friend make me a boot disk with generic CD drivers but it still won't take it. I know I'm forgetting something simple and it's been years since I've used DOS. I have floppys for DOS 6 but the computer only recognized DOS 7 and I can't find it as a DIR anywhere. Should you have supplemental knowledge I'd certainly appreciate it. I have exhausted my knowledge which wasn't all that much to begin with. I don't like giving in, out, or up. If you catch my drift. Thanks anyway, longhairlaw.
  6. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Did you try the "test" feature? It should test the CD-ROM too if it is found and present.
  7. longhairlaw

    longhairlaw TS Rookie Topic Starter

    All tested "OK". This forum is my last resort really. There are the root directorys indicated by the . and the .. if there is DOS in there? It would be the DOS7. I'm looking further into a firewire. Now I'm really out of my league. I still believe that the config.sys and autoexec.bat are the culprits. Even though I've copied them to the sys'd C: drive, set to boot from hard drive first, I reset it yesterday to boot from floppy again to try to get past the message ...insert disk 2 because I can't get the A: prompt back now. I just relearned DOS lately and maybe that's incorrect also. I'd be happy to have it back up if for only word processing with W98 back on it. I've even called some local repair shops but it's cheaper to buy another. I'm on fixed income. Thank you for your time though :)
  8. Nodsu

    Nodsu TS Rookie Posts: 9,431

    I already said, use another floppy that doesn't require a second one. There's a whole lot of DOS/Windows floppies on www.bootdisk.com with CD-ROM drivers preconfigured.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.