TechSpot

Toopid Windoz XP!!!

By ToLazyToThink
Jan 8, 2003
  1. The windows XP installion boot shows up everytime I restart my system. I don't want to choose 'boot winows xp' everytime I restart grr. The other option is 'windows xp setup' which I obviously don't need. Besides when I push that it don't work anyways. No, the XP CD is not in the drive.... Help!
     
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    go into windows explorer and choose to show all files, including hidden files and system files.

    open the file c:\boot.ini in notepad.

    post its contents here.
     
  3. Greeno

    Greeno TS Rookie Posts: 394

    or i spose a work around could be, assuming 'boot windows XP' is ur default option, and i'm guessing it stays on that screen for 30seconds etc...

    right click on my computer --> properties --> startup and recovery, then from there, choose a delay of like, 1 second or something.
     
  4. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    boot.ini>
    [Boot Loader]
    Timeout=5
    Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
    C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Setup"


    Ahhhh... That makes sense I'll screw around with this... Greeno 'startup and recovery' dosnt exist. If it was a second then I would never have time to switch it to 'boot windows Xp', though looks like I can change some thing with that boot.ini file... Thanks..
     
  5. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    What the *@)!6@8! Its read only... what kinda crap is that...
     
  6. Greeno

    Greeno TS Rookie Posts: 394

    ....anyway.... Right click on the file and choose properties, then untick the Read-Only box.

    then.....

    boot.ini>
    [Boot Loader]
    Timeout=5
    Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
    C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Setup" <-- Delete that line, problem solved
     
  7. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    Yeah, I tried though I cannot right click it to set the properties. Even when I select 'view invisable files' its umm not there... Its not viewable from command prompt either. Though maybe I can set the read-only options in command prompt anyways hmm.. If I put in notepad or address bar 'C:\boot.ini' its 'exists' lol...

    AHhh
     
  8. iss

    iss TechSpot Chancellor Posts: 2,896

    There is a small utility ( 300kb) called ReadOnly.exe that allows you to clear the read only attribute of any file or group of files with one click. you can download it here.

    http://www.sente.co.uk/downloads.htm
     
  9. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    Ok, well aparently XP has 'super hidden files' lol... In the registry I went to HKEY_CURRENT_USER \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \EXPLORER \ADVANCED under 'ShowSuperHidden' change 0 to 1 and tada. Props to http://www.tweakxp.com/tweakxp/display.asp?id=1604.

    I removed that line. Should work... Thanks for the link iss but I don't need it now...
     
  10. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    Ok, removeing that one line didnt work. So I removed everything except [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect and it works... Yay..
     
  11. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    Your boot.ini should read:

    [Boot Loader]
    Timeout=5
    Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect



    If you have that then all should be fine. its OK to cut and paste the code above in the file and then save it.


    I dunno why the S is on its own on the line below, but its meant to be part of a continous WINDOWS so that the third line of the code reads "Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS" I tried sorting it but it will not work. Anyway, I'll attach a copy of the boot.ini I think you should use....


    download this file : http://phantazmm.freeservers.com/boot.txt

    save to hdd, rename to boot.ini and save to c:\

    all should now be well
     
     
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6


    The problem with following what you said here is that its only half right. You've removed the incorrect line that you've marked in red, however the default parameter is still pointing to that. in the adsence of any valid line under operating systems that matches the default parameter, you will get some kind of funky error....
     
  13. ToLazyToThink

    ToLazyToThink TS Rookie Topic Starter

    Hmm well theres need for [boot loader]... Maybe because I don't have mulitple OS's...
     
  14. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    whether you do or not, I would leave that line in. just use the file I linked to and everything should be fine.

    its usually a good idea to have a copy of any configuration files made before you edit them as well, just in case something goes wrong. this is doubly so for boot configuration files, where you might not be able to boot your machine to fix the problem under certain circumstances...
     
  15. Greeno

    Greeno TS Rookie Posts: 394

    I do apologise, and thx for correcting me Phanta d00d :]

    [Boot Loader]
    Timeout=5
    Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

    either way, the above is the correct boot.ini you need(like you said, having read it again).

    Also, the reason you can't see the boot.ini is because, although you have clicked "Show hidden files and folders" there is another option just below saying "Hide proteced operating system files (Recommened)", untick that and all shall be revealed ;)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.