Toshiba L300 screen problem

By Bonzodog
Jun 7, 2010
Topic Status:
Not open for further replies.
  1. My wife's 2 year old Toshiba L300 laptop has started exhibiting a nasty screen problem. From start up (ie switch on and BIOS splash) the screen goes into a peculiar cycle: every 3 seconds (or very close about) the screen garbles with fine horizontal lines across the screen; it then becomes normal for a similar length of time and then garbles again.

    The brightness of the screen is unaffected so I doubt it is the inverter.

    Attaching an external screen is normal.

    Help!!
  2. Bonzodog

    Bonzodog Newcomer, in training Topic Starter

    L3000D not L300
  3. CAMusing

    CAMusing TechSpot Enthusiast Posts: 328

  4. Bonzodog

    Bonzodog Newcomer, in training Topic Starter

    Irritatingly its an SAC cable : SAC 6017B0146701
  5. mtasoriya

    mtasoriya Newcomer, in training

    Hi. I tried installing Ubuntu using a boot CD on my Staellite L300, but the screen fails when I start the installation or when I try just running Ubuntu from the CD. I just can see the initial menu of Ubuntu CD Installing. Is there any problme with VGA card compatiobility?. Thanks.
  6. kaldrouby

    kaldrouby Newcomer, in training

    swap the graphic card , check the cable and if nothing solve the problem work your way through to the Mobo .
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.