TechSpot

Toshiba Satellite L645D-S4056 no display

By benjaminABC7
Mar 27, 2013
Post New Reply
  1. Hello folks,

    I have the exact same problem - with my satellite L645D-S4036.
    I am quite sure that the hdd is still ok, and the ram is too.
    Upon power on, the power light turns on, hdd spins up, the hdd light flickers a little, then it does nothing. No backlight, no image, no error beeps either!

    Quite disappointing, as it was in sleep mode and it started doing this when I woke it up! Never had a problem with it, except for a loose solder connection on the power jack which I fixed about a year ago. I am an electrical engineering student, so I like to get some experience trying to fix this.

    The computer is about 3 years old, phenom II triple core cpu, 4g of memory, 320g hdd, and some sort of radeon graphics chip. Worse case, the graphics chip could be dead.

    No video output from external monitor connector.

    If you need more info, I will gladly share it!

    BTW, the cpu/gpu heatsink warms up as usual, and the fan runs too. VERY puzzling...

    Cheers,
    -Ben
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,757   +157

    The motherboard (GPU chip) is bad. The motherboard will have to be replaced. They are available on EBay usually for way under $150 daily


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.