TechSpot

Triple boot , Fedora Core 4 in the middle

By Liquidlen
Mar 20, 2006
  1. I've got W2k Sp4 on my IDE , Primary - Fedora Core on the Slave ,same channel
    I want to put Xp Sp 2 on a new Seagate 80 gb Sata.
    I am a relative noob with Linux , but I would like to keep it around as I would like to get to know it better. So will one of you guys give me a couple of pointers as to what to expect or what I can do to minimize any problems with this .
    If I understand correctly , the XP install will kill the LiLo currently inplace ,but the 2 Windows O/S es should get along . Then all I need to do is re-install it(lilo) after XP is loaded to regain the Boot choice , but the Fedora O/S should be O.K.
    AM i right ? or should I do something different.
     
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You are absolutely correct.

    Think through the Lilo installation procedure though. Do you have a recovery floppy for that? Or are you going to boot from the Fedora CD and use a chroot to restore the bootloader?
     
  3. Liquidlen

    Liquidlen TechSpot Paladin Topic Starter Posts: 1,094

    Thanx Nod...
    That's why I asked ...
    What is the easiest or perhaps best way ?
     
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Old Redhat instllations offered to create a boot floppy. When you boot from that, it loads the Linux from your hard drive. From there you just run "lilo" to reinstall it in the hard drive MBR.

    If you don't have that floppy, then you have to make do with some sort of shell booted from a CD. You have to point lilo to the configuration file in your original Linux installation (a la "lilo -C /mnt/etc/lilo.conf") in order to restore the MBR.
     
  5. Liquidlen

    Liquidlen TechSpot Paladin Topic Starter Posts: 1,094

    Thanx Nod...
    You will be disapointed in me , I blew it.
    In a nutshell ,(Machine #2 in Profile)I could not get my Mb to see the new SATA drive , and I tried every trick I know , Clear cmos , every variation of the 2 settings in IDE configuration ... blah ,blah ,blah...
    I ran out of time(2 Days ) I need to get XP running , so I deleted the whole Linux Instsl (I backup data I would Need for later) and put XP on the IDE slave.
    Later this year I am probably going to update hardware to Dual Core if it continues to look good .
    I'll call you back then if I hit a snag.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...