Trouble with email

By markeystech
Dec 18, 2008
Topic Status:
Not open for further replies.
  1. Good morning,

    I have a HP Pavillion Desktop computer at home, and I recently signed up for Comcast high-speed internet which is run thru a cable modem. The internet works great and is very fast. Here is my problem:

    I cannot do any kind of email. If I try to click on the login button to sign in to our account, it says "page cannot be displayed". It does this if you try to do any kind of email. This is the first time that I have ever had this problem on my computer. We didn't have internet on the computer for about a year and a half. I also went to Apple.com the other day and tried to download the latest versio of iTunes and it said "page cannot be displayed".

    Someone suggested turning off my Windows firewall. I really didn't want to do that, but I tried it, and it didn't solve anything.

    My Norton Security is out of date and needs to be updated, but I don't know if that would have anything to do with it or not.

    Any help would be greatly appreciated.

    Thank you.
  2. CCT

    CCT TechSpot Evangelist Posts: 3,556

    You are a little vague on specifics.

    Did you create a new Email account with Comcast during the install?

    Are you trying to use that account or an 'old' account on another ISP?

    Do you also use a router? Kind/type?
  3. markeystech

    markeystech Newcomer, in training Topic Starter

    I don't know how much more specific I can be. Everything that I listed is exactly what is going on.

    Yes, the Comcast technician set up our email account during the install. We are trying to use the Comcast account. I tried to go to my web-based email for work as well, and received the same message.

    There is no router being used. It is just a cable modem.
  4. CCT

    CCT TechSpot Evangelist Posts: 3,556

  5. markeystech

    markeystech Newcomer, in training Topic Starter

    I have been on the phone with Comcast 2 or 3 times with their tech support and there is nothing wrong on their end. They did all kinds of tests. The one guy finally said that he didn't know.

    I called HP and spoke to one of their techs and to do a one-time fix, it was almost $100. And there was no guarantee that it would be fixed. I am not going to pay $100 first and then the problem not be fixed. That is just stupid.

    I really don't know what to do. I guess I could renew my warranty on the computer and then contact HP. It's just very weird. I was using this computer a year and a half ago, and we were using email with no problem. At that time we had SBC Yahoo DSL.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.