TechSpot

trouble with "save as..." for .jpg

By farchima
Mar 24, 2004
  1. Now this is strange....
    In IE 6 when I right-click on a .jpg to save it, and the "save as" box comes up, I can't see ANY previously saved file names (.jpg only) in the "save as" window. It looks like I am saving a file into a brand-new folder, with nothing yet in it. The file still gets saved, but I can only see the saved file names by directly opening the folder in which they were saved. This only happens on .jpg's and is not a problem with other browsers. Just started happening 2 weeks ago. Any ideas what may be causing this?
     
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    I've seen such problems occur with IE, I often used to get a problem where for any image I would try to save, IE offered me to save it in BMP only.

    Have you tried clearing your Temporary Internet Files ? More often then not, that solves those kinds of problems.

    PS. Welcome to TechSpot. Hope you enjoy your stay.:wave:
     
  3. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    When you clck 'Save as' look near the bottom of the new window for Save as file type .If it shows only .jpg then windows is simply defaulting to show only the files .jpg
    You can bring down the menu of that same list and ckick on 'all file types' if you want to see the other files in that folder.
    Or you go directly through explorer to confirm the files in the folder you are concerned with.
    There is a control for this behaviour (which is by design) and I think it is in Folder options but I am not sure.
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Didou's advise is right, your Temp. Internet Files folder(s) are chock-a-block full. Empty them.
     
  5. farchima

    farchima TS Rookie Topic Starter

    I've tried that...actually, I empty it every day. IE 6 is allowing me to save the image as a .jpg, I just can't see previously saved .jpg's in the "save picture" window when I right-click on an image. This is only happening with IE, and not other browsers. My hair is starting to fall out, I'd better get a broom.
     
  6. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Could it be that IE is sorting on *.jpg when your files are saved with the .jpeg extension ? :confused:
     
  7. farchima

    farchima TS Rookie Topic Starter

    Ahhhh.....I found that if I type the ".jpg" extension behind the file name before I save it (even though it IS offered in the "file type" menu, then all is well. Still, I wonder why I would have to type it in manually...it used to do it automatically!
     
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Maybe you have to register .jpg and .jpeg as one and the same file type.
     
  9. farchima

    farchima TS Rookie Topic Starter

    How do you register them as the same??? I'd sure like to give it a try...
     
  10. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In Windows Explorer go to Tools->Folder Options->File Types and see if jpg and jpeg are defined exactly the same (most likely they are).
     
  11. farchima

    farchima TS Rookie Topic Starter

    Cool beans...I figured out that the files were being saved as a ".jpe". Did a few searches and found the fix here: http://www.dansdata.com/io021.htm (2nd article down).

    I had to change the extension back to .jpg in the registry, now everything is beautiful once more. Thanks for your help everyone!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...