Unable to print to network printer while connected to modem

  1. Problem:
    I have a PC that has to connect to a server through a modem for security reasons.
    While it is connected to the modem, a screen needs to be printed.
    The printer that is being used is connected to the local network.
    While connected to the modem, attempting to print gives the error "The RPC server is unavailable."

    System:
    Windows XP Professional SP3
    Printer server is Windows Server 2008
    Modem is old 56k modem connected by serial port (don't think that matters)

    What I've tried:
    I have tried modifying the routing table to force connections to the subnet that the computer and printer are hosted on.
    route -p add 10.1.0.0 MASK 255.255.255.0 10.1.61.0 METRIC 40 IF 0x2
    ip for the PC is 10.1.61.53, ip for the printer is 10.1.61.22, IF 0x2 is the integrated NIC
    The RPC service is running, and I have also started the RPC locator

    Any suggestions what I should do next?
  2. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    These are correct
    • ip for the PC is 10.1.61.53,
    • ip for the printer is 10.1.61.22, IF 0x2
    but this is not
    • route -p add 10.1.0.0 MASK 255.255.255.0 10.1.61.0
    and should not be necessary at all, if the PC gateway is on 10.1.61.x

    Instead, get the output of ROUTE PRINT and post that
  3. Rando Farmer II

    Rando Farmer II Newcomer, in training Topic Starter

    OK, so anywhere you see the 32.229.BOX, those are all the same address.

    The first print is when the modem is connected, the second is when it was disconnected.

    Attached Files:

  4. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    Line two in route table is wrong, use:
    • route -p add 10.1.61.0 MASK 255.255.255.0 10.1.61.53
    to summarize your network
    • 32.229.BOX is your ISP access
    • 10.1.61.* is a secondary NIC which goes to some internal LAN
    The internal LAN is either a router, switch or a direct connection to the printer (clarification needed)
  5. Rando Farmer II

    Rando Farmer II Newcomer, in training Topic Starter

    Your summary is correct. that 32.339.BOX is the ISP that is accessed when we connect via modem. We break up our locations by subnet, so 10.1.2.* is some place, 10.1.3.* is another, and so on. The internal LAN goes to a switch, and ip's are assigned by a DHCP server at each location that is connected to that switch. I included a diagram that I think shows it better than I can describe it.

    Attached Files:

  6. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    Hmm; that switch has an address??? very Atypical - - usually it is invisible (ignoring the hardware MAC address).

    The printer must have a fixed/static or address reservation in your DHCP server.

    The normal way to route this is
    the PC ---> next-uplink-device which will then know how to access all devices attached to it.
    (a switch does not provide routing).

    That said, I would use a routing like:
    • route -p add 10.1.61.0 MASK 255.255.255.0 10.1.61.254 metric 20 IF 0x2
    The Network Printer is defined to the PC and in that configuration, the proper address will be found (10.1.61.22). So when any application (notepad is good for testing this stuff) selects PrinterX, it will properly connect to 10.1.61.22 via the router.
    Rando Farmer II likes this.
  7. Rando Farmer II

    Rando Farmer II Newcomer, in training Topic Starter

    OK, I had to add a couple more subnets because of the way our print server is set up, but it is working now. Thank you for your solution.
  8. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    Superb :) thanks for the feedback to assist others.
  9. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    Btw: That gateway modem/router should refuse RIP updates and not reply to PING because
    1. it faces the public Internet and can be seen by everyone
    2. if RIP is allowed, you would be subject to call kinds of man-in-the-middle attacks
    Also consider to disable remote management & port 8080 access altogether.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.