Unable to run scheduled tasks

By aigle
Sep 14, 2006
  1. After a recent format and reinstall of XP home, I am not able to run scheduled tasks. The error mesages I get are as shown below. I run as administrator with no password and there are no security appliances installed yet which can interfere.
    I wonder where can be the problem as the system is just fresh, no malware as not even connected to internet yet. I was ble to run scheduled snapshots on same system before format and reinstall via recovery CD. Any help will be appreciated.


    Attached Files:

    • 1.jpg
      File size:
      71.9 KB
    • 2.jpg
      File size:
      57.9 KB
    • SchedLgU.Txt
      File size:
      25.1 KB
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Try running the task with user NT AUTHORITY/SYSTEM
    That has no password.

    Otherwise, try to run it as the current user, not administrator, unless admin IS the current user.

    I've had problem creating custom tasks myself. Maybe you should use a 3rd party scheduling program.
  3. aigle

    aigle TS Rookie Topic Starter

    Sorry I don,t understand this.
    I am current user as well as administrator. No other user.
    The most weired thing is that this system is almost exactly the same as I format with recovery CD that installs exactly same settings etc each time.
    The only new thing I have done is to run Norton clean up tool after doing uninstall of Norton Internet Security via add/ remove( that I did not do last time--- at that time I just uninstalled by add/remove and after that did not run Norton uninstall tool). But I don,t think it has any relation to current issue.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Ok, well basically I was saying try changing the user name.

    Go into the scheduled tasks panel. Then double-click a task.
    Right on the first page that shows up (Task tab) you will see a section "Run as:" This box has the username that the task runs under. Change that box to say just SYSTEM and click Apply. If you get no error, click OK.
    Now double-click the task again and see what is in the box. It should now probably say "nt authority/system". See if that works.
  5. aigle

    aigle TS Rookie Topic Starter

    Thanks I understand it now and this solution should have worked. System showed the tasks now running but I never saw them running actually.

    BTW I have found out the actual problem as well.

    From Windows Built in Help,

    "To open Scheduled Tasks, click Start, click All Programs, point to Accessories, point to System Tools, and then click Scheduled Tasks.
    If you want to configure advanced settings for the task, select the Open advanced properties for this task when I click Finish check box on the final page of the wizard.
    Confirm that the system date and time on your computer are accurate, because Scheduled Tasks relies on this information to run scheduled tasks. To verify or change this information, double-click the time indicator on the taskbar.
    [/B]If you leave the password blank and you want the task to run when you are logged on, open the task. On the Task tab, select the Run only if logged on check box. The task will run at its scheduled time when the user who created the task is logged on to the computer[/B]"

    Just checking the Run only if logged on check box solved the issue. It was my mistake.
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Hmm, glad it worked. There's one for the archives.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...