Unacceptably high disk usage/performance lag Windows 8

By SNGX1275
Feb 28, 2013
Post New Reply
  1. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Yes. C and X are the same physical drive. But every screen shot I have used in this thread showing disk usage has been with transfers from a different physical drive to C or X.
  2. jobeard

    jobeard TS Ambassador Posts: 13,010   +218

    As long as the source and destination are on different physical drives, what everyone would expect should be true - - good performance at low resource consumption.

    However, when the source and destination are on the same physical drive, the arm is moving between different (or even the same)
    partition(s) and the drive goes into hyperdrive - - poor performance and unreasonable resource consumption.
  3. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Which would be totally understandable if that is what I'm showing, but it isn't. This is and has always been a performance issue between 2 different physical drives. I'm now back at one of my original thoughts (from post #1) that this is a Windows 8 bug.
  4. Darth Shiv

    Darth Shiv TechSpot Evangelist Posts: 1,086   +154

    This is a big stab in the dark but something I became aware of recently in Win8. Your problem may be related to how Windows 8 handles timers now. Default behaviour is tickless timers. This is for power saving purposes but some drivers and components may assume the ticking timer model (of Win7 etc) and be losing performance due to this assumption.

    You can disable the tickless timer behaviour by opening a command prompt and typing

    bcdedit /set disabledynamictick true

    There is also another option to force using the high precision timer (referred to as HPET) which also helps with timer issues

    bcdedit /set useplatformclock true

    Reboot is required to apply changes...
  5. jobeard

    jobeard TS Ambassador Posts: 13,010   +218

    I had an idea that I learned when working with large SQL imports - - TURN OFF indexing on the target drive:\Folder during the copy and reenable if so desired. Also reconsider indexing content - - usually non-productive but time consuming.
  6. Darth Shiv

    Darth Shiv TechSpot Evangelist Posts: 1,086   +154

    Yeap agree... I turn off the indexes because an out of date index is useless as well as the indexes returning crap. MS's implementation is painfully hard to manage with the GUI (when you are talking thousands of extensions).
  7. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    I haven't done that yet. It may improve performance slightly, but what I'm seeing is obviously a very drastic change from what is capable between the drives to the horrible slowness and system lag. I very much doubt simple indexing is the root of the problem.
  8. Darth Shiv

    Darth Shiv TechSpot Evangelist Posts: 1,086   +154

    Yes I wouldn't expect that would solve your problem but it's just a nice system tweak...
  9. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    If you ever find out what causes this, let me know, I have the same issue with my Win8 laptop & hdd. I'm considering moving back to 7 though...
  10. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Hopefully it will be addressed by Microsoft with a patch.
  11. jobeard

    jobeard TS Ambassador Posts: 13,010   +218

    Looking at my config, the files for Index Search are kept at C:\ProgramData\Microsoft.

    Where a copy moves from x:\ --> c:\ there are at least 2x or 3x I/o events to the target C drive compared to the source on X. Ignoring multiple partitions clouding the issue,
    • the HD will be yanking the disk arm for the data block and write it,
    • then yank the arm into the C:\ProgramData\Microsoft area,
    • at lease read one block and
    • then write the new index value(s).
    When the next block from the source arrives, it is possible to repeat the whole thing again to include data values from the source file.

    Having the system Index data on the same volume as the target of the copy would seem to create imo, the worst case performance for copy.
  12. jobeard

    jobeard TS Ambassador Posts: 13,010   +218

    We can analyze the C disk issues using the Win/7 Taskmgr
    • <ctl><alt><del> gives the prompt -> taskmgr (I know YOU know, but the sequence is for those that are following the thread)
    • click Show Processes from All Users at the bottom and enter Admin/Pwd
    • click the Performance Tab
    • click Resource Monitor lower right
    • click the Overview Tab
    • of the {Cpu, Disk, Network, Memory} pull downs, click Disk
    • now click far right Total (B/sec)
    The list will then show the process name/pid & file in descending order of I/o transfer rates. Even the I/o to pagefile.sys shows up.

    (*) you will see those files creating the C drive load and if the Indexing Updates are truly impacting the outcome, then I would expect the I/o to C:\ProgramData\Microsoft to be higher than the data file(s) you are coping.

    (*) in addition, the header to the Disk Resources will contain xxKB/sec and yy% Highest Active time
  13. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Jobeard - I have never once complained about drive performance/lag here when copying C to X or X to C. None of the screenshots in this thread include that, and none of my text describing the problem includes that either. Every screenshot is a transfer between 2 different physical drives. You can notice that in the screenshots, one drive will have higher usage than the other 2 but not 100% like C and X. I even established that after you hinted that was the problem (post #27 and #28).

    So while what you said is entirely correct, it does not apply here. And I really don't want to get too off topic here, but since it seems this will remain unresolved, even if it was a transfer from C to X, the performance would be better than 10 megs a sec. I've done partition to partition transfers on the same physical drive before and while I don't remember exactly what the speeds were, I can assure you they were faster than 10 megs a second.
     
  14. jobeard

    jobeard TS Ambassador Posts: 13,010   +218

    Ok, sorry for the confusion - - I recalled that the issue was *->C and C performance was at 100% - - just call me senile :)
  15. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Just because you asked, and because I hadn't provided them yet. Here are a couple screenshots of what is happening in Resource Monitor.

    [​IMG]

    [​IMG]

    Notice K (Disk 2) was originally way up there at 100% too, then later it settled down and only X (Disk 0) was at 100%. I didn't notice anything fishy in drive access sorted by transfer speed.

    The initial transfer speed, for several seconds, was 90MB/sec which is about what I would expect. Then the dropoff occurs.

    Edits: Sorry for all the edits, had issues with the links.
  16. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Just as a follow-up.

    I nuked the Windows 8 partition and installed Windows 7. Transferring from another internal hard drive (Disk 3 in above) to my Disk 0 (C and X in above ), this happens:
    [​IMG]

    As you can see, that is a much more acceptable speed. Just to be clear - the same drives are involved (although different actual files) in each screen. Just the top grab is on Windows 8, the bottom is in Windows 7, nothing else changed.
  17. zian92

    zian92 Newcomer, in training

    Hey guy,
    I was following this thread with the big hope to find an answer to this problem...
    I have the same issue on a lenovo notebook. 100% HDD usage but less than 1 MB/s transferrate. The problem occured one day, about weeks ago. I think after an update, because the time before it worked qithout any problem.

    Searching the internet for the solution I found the following:
    http://www.bleepingcomputer.com/for...windows-8-now-constant-disk-access/?p=2931921
    I din't expet it would work, but it does:
    now I am constant under 100% diskusage, even if I coppy files from C:\ to C:\

    Let me know, if it worked for you!
    best regards
    Zian
  18. Scott Johnston

    Scott Johnston Newcomer, in training

    I've had a Windows 8 machine for 6 months. Its been perfectly fine until 5 days ago, when I started getting the 100% disk utilization problem. I've read through this thread, and there is one thing I don't think has been understood..the disk is NOT actually being used at 100%. It just says it is. When I add up the resources in use, the disk usage typically comes to 3-5% even though it says its at 100%. How Win8 handles resource management I don't know, but I generally can't do anything until the disk says its not busy (even though it actually hasn't been all along).

    I've found two things that sort of help..meaning the problem is still there but it seems to clear in a few seconds instead of 5-10 minutes. I assign HIGH priority to anything I'm running, and I keep a valid disk in the DVD drive. I tried disabling the DVD drive but that didn't seem to help.

    I'm testing a few possible sources for the problem at the moment. I'm rather suspicious of Flash Player, and there also seem to be rather a lot of update notification jobs in memory (even though I've got everything patched to most recent updates).

    People have been reporting this problem pretty much since Win8 first came out, but there just does not seem to be any common factors, and I can't find any sign that Microsoft are looking into it.
  19. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Ugh, I've tried 3 times to deal with this proper quoting and can't get it right, I give up. Content is still valid. Enjoy.
    JC713 likes this.
  20. ddayvison

    ddayvison Newcomer, in training

    Try to do this:
    To do this, follow the following steps:
    1. Go to Control Panel> All control panel items > System
    2. Click on Advanced system settings
    3. Under performance, click on settings
    4. Go to Advanced tab
    5. Under Virtual memory, click on Change
    6. UN-check "Automatically manage paging file size for all drives" check box
    7. Select your windows drive (where OS is installed)
    8. Click on Custom size radio button
    9. Set Initial size equivalent to your RAM size in MB
    10. Set Maximum size to twice of your RAM size in MB
    11. Click on Set
    12. Click on OK thrice
    13. Restart your system

    I did and the issue was resolved.

    Full information: see attachment.

    Attached Files:

    • temp.txt
      File size:
      156 bytes
      Views:
      1
  21. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Thanks for the reply. Unfortunately I had done that already, as I always create fixed pagefile sizes and try (whenever possible, and it was in this case) to put the pagefile on a different physical drive than the OS.

    Did not fix the problem in my case.
  22. MtHarrySuze

    MtHarrySuze Newcomer, in training

    I started having this problem for no apparent reason about a week ago and over the last 24hrs it got so bad I could barely use my computer. Someone said if you do the math it's not using 100% but it IS, as supported by the fact that your system basically starts to hang. The solution for me was to disable SuperFetch service. I also turned off real time protection for windows defender prior to that but I have it back on now and have no worries.

    I killed the superfetch service via task manager and then disabled it in services and bang right away disk util dropped away.

    Now disk usage is around 4-5% often zero as I would expect in a system with 16GB of ram. The boot times have returned to being very quick as well whereas over the last week it would take 3-4 minutes just to shutdown. I think it was a windows update or something that has triggered some other problem. Seemed strange that it just started a happening out of the blue.
    Diogo Barreto likes this.
  23. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 12,245   +213

    Interesting update MrHarrySuze... I wonder if you would see any real world usage effects after boot, but prior to launching commonly used programs, and then launching them. Because, essentially that is what SuperFetch was for, to make commonly used programs launch faster by preloading when nothing else was going on.

    I'm not in a good position right now to try 8 again on my main PC, and I probably won't have the desire to try it again 'for science' in the future. If I do though, I'll certainly kill superfetch and see what happens.
  24. luvhuffer

    luvhuffer TechSpot Paladin Posts: 637

    I'm with Harry on this one. Super fetch is crap. I kill it off in the registry. You can go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Memory Management\PrefetchParameters" You'll find both the super fetch and prefetch there. I disable the superfetch but leave the prefetch. My system seems none the worse for it. Just hit modify and change it to 0. And I do have a lot of programs installed but the prefetch alone seems to handle it well. I am running an ivy bridge though so I can't speak for how your system might do. I was also thinking while reading this thread about the possibility of a bad update causing this like Harry mentioned.
    Diogo Barreto likes this.
  25. Darth Shiv

    Darth Shiv TechSpot Evangelist Posts: 1,086   +154

    Yes Superfetch has always been a bit aggressive for my liking. With a SSD, you don't need fancy pre-caching algorithms. Just load on demand.

    Superfetch tended to thrash my HDD a lot when loading large games like BF3. The moment I turned it off, the thrashing was very noticeably lower - believed to be attributed to Superfetch speculatively loading game resources like maps that I knew it wasn't going to need to use. The thrashing also caused chunkiness in game which for me is unforgivable so off it went and never looked back.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.