TechSpot

  1. TechSpot Forums are dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot Forums are dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB drive has somehow gone RAW and refuses to work

By xcylent ยท 4 replies
Sep 15, 2012
Post New Reply
  1. Hey all.

    So my brother came to me an hour ago and had a bit of a dilemma, it seems his USB had decided to corrupt on him. after a thorough lecture of removing USB's safely, I took the USB and went to work.

    what I have discovered so far:

    - It is in a RAW file format
    - I have tried 4 or 5 USB recovery tools, to no avail.
    - I have not formatted it.
    - chkdsk does nothing
    - It shows up in Disk management and my computer.

    Alright, so I'm pretty much at my wits end. this is one tough nut to crack.
    and it's slightly urgent, it has a very important assignment on it.
    Friends, my brother and I would greatly appreciate any assistance.

    I'm currently installing ubunu onto a VM so I can try that.

    Thanks guys :)
     
  2. xcylent

    xcylent TS Booster Topic Starter Posts: 231   +17

    Nevermind lads and lasses, I have solved the problem myself :)
    Ubuntu to the rescue!
     
  3. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    Yay Ubuntu :)
     
  4. Mejet

    Mejet TS Rookie

    I think I have a flash drive in the same situation! it is very frustrating and the only proposed solution that I haven't attempted is to fix it on a linux OS. I have access to linux machines tomorrow during class. What did you do on Ubuntu to fix it?
     
  5. xcylent

    xcylent TS Booster Topic Starter Posts: 231   +17

    download a program called gparted then format it in ubuntu.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...