USB Flash Drive not working

By Rukichu
Apr 10, 2009
Topic Status:
Not open for further replies.
  1. Hey guys, I've really come to my wit's end with this problem. I have a PNY Attache USB 2.0 Flash Drive and for some reason it is just not working. I have a Windows XP Professional, and I've already used the flash drive on it and it worked just fine. But now, all of a sudden, it just stopped working. It works fine on all my other computers, including my Vista and my second XP Professional, but for some reason it just suddenly stopped working here. When I put it into the USB port, the light on the flash drive flashes for a moment but then it doesn't do anything. The computer doesn't even act like anything is in there. The UDISK: E icon doesn't appear in the "My Computer" window and the computer basically doesn't do anything. I know it's nothing wrong with the USB port itself because it works whenever I plug anything else into it. My flash drive is fairly new and, as said before, works fine on other computers. I already checked the USB port controls and all of them are enabled. I totally don't know what to do right now, so could someone please help me?
    Thank you!!
  2. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Help please =(
  3. xehqter

    xehqter Newcomer, in training Posts: 85

    Does the drive appear under Disk Management (Right Click My Computer -> Manage -> Disk Management?)
  4. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 4,349   +122

    There is an edit button for you if you are logged in.

    If the problem is with your computer, I would say a virus or USB problem.
    Which should probably rule out a USB problem.

    That leave viruses, its also possible that there is something wrong with your computer's drivers or such.
    Is anything unusual or appear as if your infected?

    Back to driver issues, I recommend resetting your USB ports:
    http://www.uwe-sieber.de/files/drivecleanup.zip
    Create a shortcut of the application.
    Go to the shortcut properties and the target box and type " - u" at the end.
    The entire shortcut should say ""I:\...(download path)...\driveCleenup.exe" -u"
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

  6. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Hey guys, thanks for the help~
    It doesn't show under disk management. I will try resetting all my USB Ports.
    My computer doesn't necessarily act infected, aside from some popups that randomly show up in IE (even if I'm using firefox on a popup-free website). Do you think that has something to do with it?

    **edit: I'll also check the guide too, thanks.
  7. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Is it alright to do the troubleshooting guide without disconnecting my wireless network adapter? That's the only way I can connect to the internet so I have to have it in there.
  8. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    In General, yes! HOWEVER...

    When you follow guide to reinstall USB controllers
    => DO IT WHILE IN SAFE MODE (i need to update the guide. better to do it while in safe mode)
    => And you should remove it for that step. After system reboots you should be able to reconnect and it will reinsall itself as well... but the step needs to rebuild the USB stack so all USB should be disconnected at the time (and then reinserted to be reinstalled)
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Tho from your symptoms, you might be lucky. Try running the drivecleanup utility first (after removing any USB CDs / storage device. Your USB wireless can remain connected.. That may be sufficient to fix your problem
  10. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    okay I see what you mean. I'll mess around with it a bit and try to figure something out >_< Thanks for helping me~

    **edit: oh wait, how do I run the drive cleanup utility?
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    a prior post in the thread had mentioned it or you can also click here for more detail (it's also in part2 of the guide , toward the end of it)
     
  12. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    oh okay sorry xD; I thought they were two different things. Thanks again!
  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    No prob. Give a holler if you need more help.

    It's can be a pain when you have the case of device in Device Manager under USB Mass Storage but NOT under Disk. Means it recognizes the USB device but not as a USB disk.

    If other stuff fails to clear the problem, be sure to try one of the partitioning tools (toward end of Part1) to at least see if it can identify the device as disk and recognize the data partitions on it.
  14. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    What's strange is that I find it under both categories. It still just doesn't show up in the "My Computer" window. I really don't understand the problem here...I've tried the driver cleanup but it still didn't work. I'll check the other tools as well...
    in the meantime, do you have any other suggestions? I think this might be a deeper problem than meets the eye; my "Disk Management" window is completely blank, and I know that isn't normal...could this issue be related?
  15. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    OH.

    Check again. If you are certain your flash drive is showing up in Device Manager under both Disk Drives and USB as a Mass Storage Devices is a good thing.

    If you're also saying when you look in Computer Disk Management and you see no disks / no nothing there? or just not your flash drive?
  16. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    I tried doing TweakUI from the guide and it doesn't work. But yes, it does show up in both the Disk Drives Category and in the USB as a mass storage device.
    And yeah, nothing shows up in my disk management at all. Not a single thing, it is completely blank. The only thing that shows up is a square at the bottom that says "CD ROM" something-or-other.
  17. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    the good news is the flash drive is there and being recognized correctly at the Windows Device level (i.e. Device Manager) if you see both of its drivers there

    The fact disk management shows blank (not even your C: drive?) tho might be:
    1) A problem with your Windows services or
    2) A virus/malware infection :(

    see this thread

    And also Click here for Virus/Malware Removal Instructions.

    I'd suggest keeping the USB flash disconnected until you complete checking for 1 and 2 above and you can get your disk management working correctly.

    If steps to check for viruses indicates any problem, suggest you also start a new thread in the Virus/malware section so the experts there can help

    /* EDIT */
    Gotta run for now. But will look back / check in on ya later!
  18. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Okay thank you so much for that.
    As for the Windows Services issue, if that is the case, do you suggest that it's because I need Service Pack 3? I only have Service Pack 2 right now...does that make a difference with the drivers or something?

    **edit: I also wanted to say that no, I don't see my C: drive either. It's really strange. But anyway, thanks for all your help and I hope you make it back before I leave >_< (I'm going on vacation so I won't be touching my computer for another 4 or so days xP )
  19. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    just caught your last post before having to log out!

    glad you mentioned that (reminds me i should update the guide as well)...

    1) SP3 has a couple USB bug fixes in fact. (Services no different SP3 vs SP2) Not sure if SP3 addresses your problem but is good to do an SP3 install. However,
    2) I'd also do the virus check first. AT least see the instructions and run a HijackThis report to post for in Virus section for others to review (and note your Disk Management) issue as well. Is better to make sure you're virus free before trying to SP3 update
    3) Also, if by chance you have IE8 installed, remove it before the SP3 upgrade. (If installed when you upgrade you lose the ability to uninstall IE8. If IE7 is installed at time of upgrade, you can still IE8 after SP3 and still then have option to uninstall IE8
  20. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Okay thanks for that information. I'll try to see if it's a virus issue.
    I actually have IE6 (long story, really..) so I don't need to worry about that. I'll check the other thread link you showed me first and then I'll post something in the virus section. (probably after my vacation since I'm leaving in a few hours)
    Thanks again for all of your help, you really are awesome!
  21. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Alrighty, I'm back from vacation and I'm going to look into those other things mentioned. In the meantime, if anyone else has any suggestions I would greatly appreciate it!
  22. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    just.. fyi.. i'm working on an update version of Part1 Troubleshooting Guide (i think it will be clearer to follow.. and maybe some more stuff).. so whether begin now or want to wait till end of week.. in either case will publish a new draft copy for you here by end of week... (But today is still full-time finishing my US and State taxes. I know it's last minute, but, hey, i owe them both $$ so i was in no hurry to write those checks!):D
  23. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Okay, I'll take a look at that when you've finished it; thanks! ^^ And wow you did your taxes REALLY late xD Mine were finished in February!
  24. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    i just recalled there we decided malware was possible in your situation. So you can at least start with the Malware links provided in current version of Part1. Will likely take you a day or two just to finish that process
  25. Rukichu

    Rukichu Newcomer, in training Topic Starter Posts: 52

    Yeah, well I had dealt with a virus issue a bit recently (maybe 2-3 months ago?) and I cleaned it all out but I'm still wondering if maybe little things are in there. What's really strange is that the flash drive was working perfectly around that time and after I removed the malware. Its behavior was completely random to say the least. I just hope I can figure it out =(
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.