USB flash drive prob

By Morpher
Jun 21, 2005
  1. I, i have a 512mb flash drive from pny, a few days ago i was copying some files from the drive when the ligths in my house went out, now every time i try to acess the drive it says the drive needs to be formated but when i try to format it it says that the drive is write protected. The drive has a switch on the side to change write protection on or off but i already to format with the switch in both positions and no luck. If i check the properties of the drive it says the filesystem is raw. Any ideas on how to fix it? i already tried pny tech support with no luck
  2. halo71

    halo71 TS Rookie Posts: 1,090

    Welcome to TS Morpher...

    Have you tried the SEARCH feature here yet? There have been numerous threads started about this same issue lately that may be of help to you.
  3. Morpher

    Morpher TS Rookie Topic Starter

    Yes i did, i found another user who as more or less the same prob than me but no answers there
    Also found a lot of threads about probs with write protection but none of the solutions presented worked
  4. halo71

    halo71 TS Rookie Posts: 1,090

    Same here! The issues I posted about are still an issue with my flash drive as well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...