USB Mouse\keyboard dead

By Docjsj
Jan 14, 2009
Topic Status:
Not open for further replies.
  1. I was forced to reload XP Pro on my SX280. When I loaded SP2, the USB Mouse and the keyboard went DEAD! I tried to load SP3, but wouldn't load. I used the microsoft update site for both SP2 & SP3 Without the mouse or keyboard I'm limited on what I can do. Help!!!!

    The system is Dell Optiplex SX280 Bios A09
    USB mouse & keyboard
    Windows XP Pro
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    Are you in Safe Mode?
  3. Docjsj

    Docjsj Newcomer, in training Topic Starter

    No, not in safe mode. I did reload windows in the repair mode, then I down loaded SP2 without reboot, and updated the Bios to the latest revision. Then I rebooted. I did not lose my USB ports this time. I am going to trry to update windows to SP3 now without losing my USB ports. I'm keeping my fingers crossed! Thanks. Docjsj
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    So mouse and keyboard are working okay now?
  5. Docjsj

    Docjsj Newcomer, in training Topic Starter

    Yes

    Hooray!!!! Yes, it worked! Thanks to all.
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    Good. Thanks for the update.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.