TechSpot

USB problem

By andoyan
Sep 7, 2010
Post New Reply
  1. hello All,
    I Owen a Sony PC PCV-RZ10/RX800 series and for the last two weeks it has have a problem with the usb, the only device that works is the Microsoft wireless mouse, I even have changed the usb port of the mouse and still works but other than that no other device is working!! every time I attach a usb device to one of the ports i get the following massage: usb device not recognized massage continues with one of the usb devices attached to this computer has malfunctioned and window dose not recognized it. for assistant in solving this problem click here once I click the icon that the smaller massage point it out to me , I get an new small window with a heading "usb device not recognized" right below that is usb root hub (6ports) the there are images of usb icons with a exception of one .is in bold and it says Unknown device!!
    If any body can help me with this problem I will be greatly appreciated.
    Thanks again
    Jon
     
  2. EDO219

    EDO219 TS Rookie Posts: 298

    Which OS are you using and (besides the mouse) what type of USB devices have you tried with your PC?

    Also, have any of the USB devices which are not currently working ever worked on your PC before?
     
  3. andoyan

    andoyan TS Rookie Topic Starter Posts: 82

    i am using the xp home edition and I have tried the printer, I also tried the mp3, as for the USB devices all of them were working fine!!!
    Thanks for your help.
     
  4. techsuitor

    techsuitor TS Rookie Posts: 145

    did you reformat your computer ?

    try to update your windows first
     
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,373   +167



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.